summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-11-18 19:09:16 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-11-19 06:02:37 +1100
commit59e9c4717cbd78fc72bf4a2573a693a6d494411a (patch)
treeb66b18c60b6ea66acfeee7c8c578977e0befa6a6 /kde-frameworks/kpackage
parentdev-vcs/git: bump. (diff)
downloadgentoo-59e9c4717cbd78fc72bf4a2573a693a6d494411a.tar.gz
gentoo-59e9c4717cbd78fc72bf4a2573a693a6d494411a.tar.bz2
gentoo-59e9c4717cbd78fc72bf4a2573a693a6d494411a.zip
kde-frameworks/kpackage: Add fix for <=Plasma-5.8
5.28.0 left users with a broken desktop without pre-existing config. Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-frameworks/kpackage')
-rw-r--r--kde-frameworks/kpackage/files/kpackage-5.28.0-install-metadata.patch30
-rw-r--r--kde-frameworks/kpackage/kpackage-5.28.0-r1.ebuild32
2 files changed, 62 insertions, 0 deletions
diff --git a/kde-frameworks/kpackage/files/kpackage-5.28.0-install-metadata.patch b/kde-frameworks/kpackage/files/kpackage-5.28.0-install-metadata.patch
new file mode 100644
index 000000000000..f79cc3540234
--- /dev/null
+++ b/kde-frameworks/kpackage/files/kpackage-5.28.0-install-metadata.patch
@@ -0,0 +1,30 @@
+From e7861d979c71815a614f2baf0b3d25f329fadef0 Mon Sep 17 00:00:00 2001
+From: Marco Martin <notmart@gmail.com>
+Date: Fri, 18 Nov 2016 15:51:49 +0100
+Subject: keep installing metadata.desktop
+
+there are too many existing users that rely on existence of metadata.desktop,
+so keep installing it, even if with new plasma-workspace releases only the
+metadata.json would be used. the framework should never change its behavior
+wrt old software, even if it was doing something in a sense wrong
+CCMAIL: Aleix Pol Gonzalez <aleixpol@kde.org>
+BUG:372594
+---
+ KF5PackageMacros.cmake | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/KF5PackageMacros.cmake b/KF5PackageMacros.cmake
+index cc5aae2..a14ab0b 100644
+--- a/KF5PackageMacros.cmake
++++ b/KF5PackageMacros.cmake
+@@ -31,7 +31,6 @@ function(kpackage_install_package dir component)
+ set(install_dir ${KPACKAGE_RELATIVE_DATA_INSTALL_DIR})
+ endif()
+ install(DIRECTORY ${dir}/ DESTINATION ${KDE_INSTALL_DATADIR}/${install_dir}/${root}/${component}
+- PATTERN metadata.desktop EXCLUDE
+ PATTERN .svn EXCLUDE
+ PATTERN CMakeLists.txt EXCLUDE
+ PATTERN Messages.sh EXCLUDE
+--
+cgit v0.11.2
+
diff --git a/kde-frameworks/kpackage/kpackage-5.28.0-r1.ebuild b/kde-frameworks/kpackage/kpackage-5.28.0-r1.ebuild
new file mode 100644
index 000000000000..24d83c5aa949
--- /dev/null
+++ b/kde-frameworks/kpackage/kpackage-5.28.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework to install and load packages of non binary content"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="man"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+PATCHES=( "${FILESDIR}/${P}-install-metadata.patch" ) # fix for <=Plasma-5.8
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}