summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-10 18:44:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-11 22:46:06 +0200
commit05f9f232bd47f385b9095d053928764a6c13f863 (patch)
treeb3de9e3aa060d66521432246f901ddb0ea4fa9d5 /kde-frameworks/kquickcharts
parentkde-frameworks/kplotting: 5.84.0 version bump (diff)
downloadgentoo-05f9f232bd47f385b9095d053928764a6c13f863.tar.gz
gentoo-05f9f232bd47f385b9095d053928764a6c13f863.tar.bz2
gentoo-05f9f232bd47f385b9095d053928764a6c13f863.zip
kde-frameworks/kquickcharts: 5.84.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kquickcharts')
-rw-r--r--kde-frameworks/kquickcharts/Manifest1
-rw-r--r--kde-frameworks/kquickcharts/kquickcharts-5.84.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-frameworks/kquickcharts/Manifest b/kde-frameworks/kquickcharts/Manifest
index 384867d74124..8329555b373a 100644
--- a/kde-frameworks/kquickcharts/Manifest
+++ b/kde-frameworks/kquickcharts/Manifest
@@ -1,2 +1,3 @@
DIST kquickcharts-5.82.0.tar.xz 105832 BLAKE2B 00bd1f5ff89e11758607a9b6c2705d4c670107b18eb5ac67522b1f5a6ba5f4b5897b86582ad6ea5f2a1e9245efdf52614a6ee418ff0c2ff8a0499de5211bfe49 SHA512 978e9644d62a3bc7c9e5fddbc7ce67551941a2429804d93a5745584c28555a748f7804287162e31217082bb9e9391d2d86bb50eda209f93da15cb4b5c93ed583
DIST kquickcharts-5.83.0.tar.xz 105896 BLAKE2B 9a00e87e93010dc3fe227ff0765f3ddd157594dc0d66b03d6dbd4ab52b034eebe009e534594619aadd0ba81d6767053e3b59a4dce632a480d64f54862c68af54 SHA512 d7f46a452936f89c5d50d3891ef5b4410a0c8e1fdea9ab9cd39398ddffb77c4a4b3eccec584153697010a0260f0f245c9af6c5eb6a188df8684c4d220092326f
+DIST kquickcharts-5.84.0.tar.xz 105904 BLAKE2B c152ce8a6006dd7b10af7480a83317ce867a0a851d5aa7bc6a1c4efc5452fa17b76087cb749f5e0413d08c5f2e0432d9753b309abc436d3ee65f70460a1ede66 SHA512 3ab10af399893e41ecf90eec24cd1135e35e850cfa14b621734018fc4bfae71bfa231d13e4296edb10809f6b10b1cd67cbaa0c3e9476e2e3ebd8a023bb85006f
diff --git a/kde-frameworks/kquickcharts/kquickcharts-5.84.0.ebuild b/kde-frameworks/kquickcharts/kquickcharts-5.84.0.ebuild
new file mode 100644
index 000000000000..6d75dca5d2aa
--- /dev/null
+++ b/kde-frameworks/kquickcharts/kquickcharts-5.84.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_EXAMPLES="true"
+ECM_QTHELP="false"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="QtQuick plugin providing high-performance charts"
+HOMEPAGE="https://invent.kde.org/frameworks/kquickcharts"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ examples? (
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kdeclarative-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ )
+
+ ecm_src_configure
+}