summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-09 12:40:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-07-09 16:27:05 +0200
commita36c06e0d446e6a1fc6418c0bb33bd82017a5169 (patch)
tree388f626ac14f3fe99f2021c518c510fe4ff50723 /kde-frameworks/kquickcharts
parentkde-frameworks/kplotting: 5.96.0 version bump (diff)
downloadgentoo-a36c06e0d446e6a1fc6418c0bb33bd82017a5169.tar.gz
gentoo-a36c06e0d446e6a1fc6418c0bb33bd82017a5169.tar.bz2
gentoo-a36c06e0d446e6a1fc6418c0bb33bd82017a5169.zip
kde-frameworks/kquickcharts: 5.96.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kquickcharts')
-rw-r--r--kde-frameworks/kquickcharts/Manifest1
-rw-r--r--kde-frameworks/kquickcharts/kquickcharts-5.96.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-frameworks/kquickcharts/Manifest b/kde-frameworks/kquickcharts/Manifest
index 2958310e2c25..edff1d5a8b47 100644
--- a/kde-frameworks/kquickcharts/Manifest
+++ b/kde-frameworks/kquickcharts/Manifest
@@ -1,2 +1,3 @@
DIST kquickcharts-5.92.0.tar.xz 108900 BLAKE2B 36e2fef1a5a9d32a4680a2f4c8bba55508e6212050d4209be1589a962380ab03ec84d8688a61ae4dc5dbe75aca5e901f7e2fd42416e4c13bafdb369854d81135 SHA512 0e5ce7bd97e9654856066ce44068c7573370d4e33fc708d38a4350d15ec35d2a078b6891d6cfb22321e082b979301f5a03e82bb9268a5aab6b3958bb0a0a54af
DIST kquickcharts-5.95.0.tar.xz 108876 BLAKE2B 6a5f8d0e8924f0f1ba51ba3162d654683802a6ad52a139f0b389f52dc7b281dec89f0ecbe99df8b4d722aba42817c56ec919a625730a057294645fab93b91782 SHA512 a02f862e46d26563f9247b6b98c665065983be7efda62ac7c19bb634406a12400b5b2ff090db74157933546deed8a16c53edce56753989a95e7ef0ead8364693
+DIST kquickcharts-5.96.0.tar.xz 108884 BLAKE2B 3e0408144290b620092ca81b85b2122951e6a1a5a90cf88e4c00f0df35f620d2d5e1c2fc01cc717342e6d49d5ba2439026113b990840ae2097c7ca5fcdbcfb7b SHA512 306b4794eb44b7480a2cd85274d99b070184948d6bdc4a1f32c74360bdb5a48a25ffa913c743589ac58d10602f35708fb50e9111f7fac6de74b3986f9e410c7d
diff --git a/kde-frameworks/kquickcharts/kquickcharts-5.96.0.ebuild b/kde-frameworks/kquickcharts/kquickcharts-5.96.0.ebuild
new file mode 100644
index 000000000000..0fe9cb743429
--- /dev/null
+++ b/kde-frameworks/kquickcharts/kquickcharts-5.96.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_EXAMPLES="true"
+ECM_QTHELP="false"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.4
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="QtQuick plugin providing high-performance charts"
+HOMEPAGE="https://invent.kde.org/frameworks/kquickcharts"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ examples? (
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kdeclarative-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ )
+
+ ecm_src_configure
+}