summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-04-30 23:36:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-05-04 22:49:54 +0200
commitbaf8b2ac95077160b63c80e2bc37929742c7b424 (patch)
treeb619391b2efa0cef484fd487b5b13fb588332b21 /kde-frameworks/ktexteditor
parentkde-frameworks/kservice: drop 5.90.0* (diff)
downloadgentoo-baf8b2ac95077160b63c80e2bc37929742c7b424.tar.gz
gentoo-baf8b2ac95077160b63c80e2bc37929742c7b424.tar.bz2
gentoo-baf8b2ac95077160b63c80e2bc37929742c7b424.zip
kde-frameworks/ktexteditor: drop 5.90.0*
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/ktexteditor')
-rw-r--r--kde-frameworks/ktexteditor/Manifest1
-rw-r--r--kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-CVE-2022-23853-1.patch104
-rw-r--r--kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-CVE-2022-23853-2.patch55
-rw-r--r--kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-KDEBUG-447972.patch26
-rw-r--r--kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-revert-5dce70a9.patch138
-rw-r--r--kde-frameworks/ktexteditor/ktexteditor-5.90.0-r2.ebuild61
6 files changed, 0 insertions, 385 deletions
diff --git a/kde-frameworks/ktexteditor/Manifest b/kde-frameworks/ktexteditor/Manifest
index ed403c33039f..ebe34c54e8eb 100644
--- a/kde-frameworks/ktexteditor/Manifest
+++ b/kde-frameworks/ktexteditor/Manifest
@@ -1,3 +1,2 @@
-DIST ktexteditor-5.90.0.tar.xz 2340540 BLAKE2B eceb56847e43c7d8e8883bc219228ec365bf85cb5279ef255f59d3005a5e1fb6cbc55309b9791b5cdc088201283a08f5b0ab9c0fd840604c349442e60bfa4a0f SHA512 7c63802a4d904d2e5eff6e3c957e9a94848993898bdd37eb033842d4033985820348d81080a3701db19aef1a5762ebdc8a4a4749c931d79f00c986837faa5837
DIST ktexteditor-5.92.0.tar.xz 2347752 BLAKE2B c4e2356132f535dccbea1bae2355f3455b91d98c1cd99735db0ec39f0b2bc68f062e60e85f085e3614420d673487ea436243be485b321576022243736dec9f57 SHA512 5455fd579047db0010036afe0490620089687e206440ff77af270d9dcc25c1d48b3b8d763144f416cc539038c29e0e70703a1300b7ad78d0db59320a0712c402
DIST ktexteditor-5.93.0.tar.xz 2376176 BLAKE2B b0c0591adcf745eab3c2b0f016ec879834b5923aa76e4031843b9de72c35ac03ab3258dd313dd643bbe98aaf68af481e6f99e95320e98bfa5b5ad0acca938024 SHA512 a50a0bf02bea5c27460aaf2074a4e1226279bf8d540afec8dcfca5cb96250718a4c40b6fba1522d293f458a497aef3bfe804e57539edf8af9e460d88ee75db68
diff --git a/kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-CVE-2022-23853-1.patch b/kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-CVE-2022-23853-1.patch
deleted file mode 100644
index 854cf0da4b2e..000000000000
--- a/kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-CVE-2022-23853-1.patch
+++ /dev/null
@@ -1,104 +0,0 @@
-From 804e49444c093fe58ec0df2ab436565e50dc147e Mon Sep 17 00:00:00 2001
-From: Christoph Cullmann <cullmann@kde.org>
-Date: Thu, 20 Jan 2022 09:46:34 +0100
-Subject: [PATCH] only start programs in user's path
-
-don't use QProcess with just program name
-first search the right program in the user's path
----
- src/document/katedocument.cpp | 29 ++++++++++++++++------------
- src/swapfile/kateswapdiffcreator.cpp | 17 ++++++++++++----
- 2 files changed, 30 insertions(+), 16 deletions(-)
-
-diff --git a/src/document/katedocument.cpp b/src/document/katedocument.cpp
-index 01f74da1..05d0e91b 100644
---- a/src/document/katedocument.cpp
-+++ b/src/document/katedocument.cpp
-@@ -72,6 +72,7 @@
- #include <QMimeDatabase>
- #include <QProcess>
- #include <QRegularExpression>
-+#include <QStandardPaths>
- #include <QTemporaryFile>
- #include <QTextCodec>
- #include <QTextStream>
-@@ -5054,18 +5055,22 @@ void KTextEditor::DocumentPrivate::slotDelayedHandleModOnHd()
- // skip that, if document is modified!
- // only do that, if the file is still there, else reload makes no sense!
- if (m_modOnHd && !isModified() && QFile::exists(url().toLocalFile())) {
-- QProcess git;
-- const QStringList args{QStringLiteral("cat-file"), QStringLiteral("-e"), QString::fromUtf8(oldDigest)};
-- git.start(QStringLiteral("git"), args);
-- if (git.waitForStarted()) {
-- git.closeWriteChannel();
-- if (git.waitForFinished()) {
-- if (git.exitCode() == 0) {
-- // this hash exists still in git => just reload
-- m_modOnHd = false;
-- m_modOnHdReason = OnDiskUnmodified;
-- m_prevModOnHdReason = OnDiskUnmodified;
-- documentReload();
-+ // we only want to use git from PATH, cache this
-+ static const QString fullGitPath = QStandardPaths::findExecutable(QStringLiteral("git"));
-+ if (!fullGitPath.isEmpty()) {
-+ QProcess git;
-+ const QStringList args{QStringLiteral("cat-file"), QStringLiteral("-e"), QString::fromUtf8(oldDigest)};
-+ git.start(fullGitPath, args);
-+ if (git.waitForStarted()) {
-+ git.closeWriteChannel();
-+ if (git.waitForFinished()) {
-+ if (git.exitCode() == 0) {
-+ // this hash exists still in git => just reload
-+ m_modOnHd = false;
-+ m_modOnHdReason = OnDiskUnmodified;
-+ m_prevModOnHdReason = OnDiskUnmodified;
-+ documentReload();
-+ }
- }
- }
- }
-diff --git a/src/swapfile/kateswapdiffcreator.cpp b/src/swapfile/kateswapdiffcreator.cpp
-index 5c515c45..a185123a 100644
---- a/src/swapfile/kateswapdiffcreator.cpp
-+++ b/src/swapfile/kateswapdiffcreator.cpp
-@@ -14,6 +14,7 @@
- #include <KMessageBox>
-
- #include <QDir>
-+#include <QStandardPaths>
- #include <QTextCodec>
-
- // BEGIN SwapDiffCreator
-@@ -85,17 +86,25 @@ void SwapDiffCreator::viewDiff()
- connect(&m_proc, &QProcess::readyRead, this, &SwapDiffCreator::slotDataAvailable, Qt::UniqueConnection);
- connect(&m_proc, &QProcess::finished, this, &SwapDiffCreator::slotDiffFinished, Qt::UniqueConnection);
-
-- // try to start diff process, if we can't be started be done with error
-- m_proc.start(QStringLiteral("diff"), QStringList() << QStringLiteral("-u") << m_originalFile.fileName() << m_recoveredFile.fileName());
-- if (!m_proc.waitForStarted()) {
-+ // use diff from PATH only => inform if not found at all
-+ const QString fullDiffPath = QStandardPaths::findExecutable(QStringLiteral("diff"));
-+ if (fullDiffPath.isEmpty()) {
- KMessageBox::sorry(nullptr,
-- i18n("The diff command could not be started. Please make sure that "
-+ i18n("The diff command could not be found. Please make sure that "
- "diff(1) is installed and in your PATH."),
- i18n("Error Creating Diff"));
- deleteLater();
- return;
- }
-
-+ // try to start the diff program, might fail, too
-+ m_proc.start(fullDiffPath, QStringList() << QStringLiteral("-u") << m_originalFile.fileName() << m_recoveredFile.fileName());
-+ if (!m_proc.waitForStarted()) {
-+ KMessageBox::sorry(nullptr, i18n("The diff command '%1' could not be started.").arg(fullDiffPath), i18n("Error Creating Diff"));
-+ deleteLater();
-+ return;
-+ }
-+
- // process is up and running, we can write data to it
- QTextStream ts(&m_proc);
- int lineCount = recoverDoc.lines();
---
-GitLab
-
diff --git a/kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-CVE-2022-23853-2.patch b/kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-CVE-2022-23853-2.patch
deleted file mode 100644
index 8cccfe3a95b0..000000000000
--- a/kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-CVE-2022-23853-2.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From c80f935c345de2e2fb10635202800839ca9697bf Mon Sep 17 00:00:00 2001
-From: Christoph Cullmann <cullmann@kde.org>
-Date: Thu, 20 Jan 2022 10:30:20 +0100
-Subject: [PATCH] only execute diff in path
-
----
- src/dialogs/katedialogs.cpp | 5 +++--
- src/dialogs/katedialogs.h | 1 +
- 2 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/src/dialogs/katedialogs.cpp b/src/dialogs/katedialogs.cpp
-index 5b949f36..63a58aee 100644
---- a/src/dialogs/katedialogs.cpp
-+++ b/src/dialogs/katedialogs.cpp
-@@ -1317,6 +1317,7 @@ KateModOnHdPrompt::KateModOnHdPrompt(KTextEditor::DocumentPrivate *doc, KTextEdi
- : QObject(doc)
- , m_doc(doc)
- , m_modtype(modtype)
-+ , m_fullDiffPath(QStandardPaths::findExecutable(QStringLiteral("diff")))
- , m_proc(nullptr)
- , m_diffFile(nullptr)
- , m_diffAction(nullptr)
-@@ -1334,7 +1335,7 @@ KateModOnHdPrompt::KateModOnHdPrompt(KTextEditor::DocumentPrivate *doc, KTextEdi
- m_message->addAction(aAutoReload, false);
- connect(aAutoReload, &QAction::triggered, this, &KateModOnHdPrompt::autoReloadTriggered);
-
-- if (!QStandardPaths::findExecutable(QStringLiteral("diff")).isEmpty()) {
-+ if (!m_fullDiffPath.isEmpty()) {
- m_diffAction = new QAction(i18n("View &Difference"), this);
- m_diffAction->setIcon(QIcon::fromTheme(QStringLiteral("document-multiple")));
- m_diffAction->setToolTip(i18n("Shows a diff of the changes"));
-@@ -1394,7 +1395,7 @@ void KateModOnHdPrompt::slotDiff()
- // Start a KProcess that creates a diff
- m_proc = new KProcess(this);
- m_proc->setOutputChannelMode(KProcess::MergedChannels);
-- *m_proc << QStringLiteral("diff") << QStringLiteral("-u") << QStringLiteral("-") << m_doc->url().toLocalFile();
-+ *m_proc << m_fullDiffPath << QStringLiteral("-u") << QStringLiteral("-") << m_doc->url().toLocalFile();
- connect(m_proc, &KProcess::readyRead, this, &KateModOnHdPrompt::slotDataAvailable);
- connect(m_proc, &KProcess::finished, this, &KateModOnHdPrompt::slotPDone);
-
-diff --git a/src/dialogs/katedialogs.h b/src/dialogs/katedialogs.h
-index 80b611d9..e5574023 100644
---- a/src/dialogs/katedialogs.h
-+++ b/src/dialogs/katedialogs.h
-@@ -376,6 +376,7 @@ private:
- KTextEditor::DocumentPrivate *m_doc;
- QPointer<KTextEditor::Message> m_message;
- KTextEditor::ModificationInterface::ModifiedOnDiskReason m_modtype;
-+ QString m_fullDiffPath;
- KProcess *m_proc;
- QTemporaryFile *m_diffFile;
- QAction *m_diffAction;
---
-GitLab
-
diff --git a/kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-KDEBUG-447972.patch b/kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-KDEBUG-447972.patch
deleted file mode 100644
index 05cfbd107cd9..000000000000
--- a/kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-KDEBUG-447972.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 863f606b1fcf3b91b256d9167a00539289246188 Mon Sep 17 00:00:00 2001
-From: Waqar Ahmed <waqar.17a@gmail.com>
-Date: Tue, 11 Jan 2022 20:03:12 +0500
-Subject: [PATCH] Find: Update working range when replacing
-
-BUG: 447972
----
- src/search/katesearchbar.cpp | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/search/katesearchbar.cpp b/src/search/katesearchbar.cpp
-index ed52c4cb..c1c85bd4 100644
---- a/src/search/katesearchbar.cpp
-+++ b/src/search/katesearchbar.cpp
-@@ -843,6 +843,8 @@ void KateSearchBar::findOrReplaceAll()
-
- // Replace
- lastRange = match.replace(m_replacement, false, ++m_matchCounter);
-+ // update working range as text must have changed now
-+ workingRangeCopy = m_workingRange->toRange();
- } else {
- lastRange = match.range();
- ++m_matchCounter;
---
-GitLab
-
diff --git a/kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-revert-5dce70a9.patch b/kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-revert-5dce70a9.patch
deleted file mode 100644
index 140bc0cf7111..000000000000
--- a/kde-frameworks/ktexteditor/files/ktexteditor-5.90.0-revert-5dce70a9.patch
+++ /dev/null
@@ -1,138 +0,0 @@
-From 3b31919427baf3da1ab1a24f682a4cefc7e5106f Mon Sep 17 00:00:00 2001
-From: Christoph Cullmann <cullmann@kde.org>
-Date: Sun, 16 Jan 2022 18:29:57 +0100
-Subject: [PATCH] Revert "Do not cancel mouse selection when using the
- keyboard"
-
-This reverts commit 5dce70a9693f8cce37f733b4687bb9b303376742.
-
-=> this leads to regressions
-
-if somebody has time to properly reproduce and fix that, we can reapply
-this, otherwise it is better to have some always working state without
-this small usability improvement
-
-BUG: 447525
-BUG: 446189
-
-frameworks/ktexteditor#11
----
- src/view/kateview.cpp | 20 ++++++++++----------
- src/view/kateviewinternal.cpp | 5 -----
- src/view/kateviewinternal.h | 2 --
- 3 files changed, 10 insertions(+), 17 deletions(-)
-
-diff --git a/src/view/kateview.cpp b/src/view/kateview.cpp
-index 6b88eb75..56348480 100644
---- a/src/view/kateview.cpp
-+++ b/src/view/kateview.cpp
-@@ -3063,9 +3063,9 @@ void KTextEditor::ViewPrivate::shiftCursorRight()
- void KTextEditor::ViewPrivate::wordLeft()
- {
- if (currentTextLine().isRightToLeft()) {
-- m_viewInternal->wordNext(m_viewInternal->isUserSelecting());
-+ m_viewInternal->wordNext();
- } else {
-- m_viewInternal->wordPrev(m_viewInternal->isUserSelecting());
-+ m_viewInternal->wordPrev();
- }
- }
-
-@@ -3081,9 +3081,9 @@ void KTextEditor::ViewPrivate::shiftWordLeft()
- void KTextEditor::ViewPrivate::wordRight()
- {
- if (currentTextLine().isRightToLeft()) {
-- m_viewInternal->wordPrev(m_viewInternal->isUserSelecting());
-+ m_viewInternal->wordPrev();
- } else {
-- m_viewInternal->wordNext(m_viewInternal->isUserSelecting());
-+ m_viewInternal->wordNext();
- }
- }
-
-@@ -3098,7 +3098,7 @@ void KTextEditor::ViewPrivate::shiftWordRight()
-
- void KTextEditor::ViewPrivate::home()
- {
-- m_viewInternal->home(m_viewInternal->isUserSelecting());
-+ m_viewInternal->home();
- }
-
- void KTextEditor::ViewPrivate::shiftHome()
-@@ -3108,7 +3108,7 @@ void KTextEditor::ViewPrivate::shiftHome()
-
- void KTextEditor::ViewPrivate::end()
- {
-- m_viewInternal->end(m_viewInternal->isUserSelecting());
-+ m_viewInternal->end();
- }
-
- void KTextEditor::ViewPrivate::shiftEnd()
-@@ -3118,7 +3118,7 @@ void KTextEditor::ViewPrivate::shiftEnd()
-
- void KTextEditor::ViewPrivate::up()
- {
-- m_viewInternal->cursorUp(m_viewInternal->isUserSelecting());
-+ m_viewInternal->cursorUp();
- }
-
- void KTextEditor::ViewPrivate::shiftUp()
-@@ -3128,7 +3128,7 @@ void KTextEditor::ViewPrivate::shiftUp()
-
- void KTextEditor::ViewPrivate::down()
- {
-- m_viewInternal->cursorDown(m_viewInternal->isUserSelecting());
-+ m_viewInternal->cursorDown();
- }
-
- void KTextEditor::ViewPrivate::shiftDown()
-@@ -3168,7 +3168,7 @@ void KTextEditor::ViewPrivate::shiftBottomOfView()
-
- void KTextEditor::ViewPrivate::pageUp()
- {
-- m_viewInternal->pageUp(m_viewInternal->isUserSelecting());
-+ m_viewInternal->pageUp();
- }
-
- void KTextEditor::ViewPrivate::shiftPageUp()
-@@ -3178,7 +3178,7 @@ void KTextEditor::ViewPrivate::shiftPageUp()
-
- void KTextEditor::ViewPrivate::pageDown()
- {
-- m_viewInternal->pageDown(m_viewInternal->isUserSelecting());
-+ m_viewInternal->pageDown();
- }
-
- void KTextEditor::ViewPrivate::shiftPageDown()
-diff --git a/src/view/kateviewinternal.cpp b/src/view/kateviewinternal.cpp
-index d642938a..c8d479d6 100644
---- a/src/view/kateviewinternal.cpp
-+++ b/src/view/kateviewinternal.cpp
-@@ -4077,11 +4077,6 @@ void KateViewInternal::viewSelectionChanged()
- m_selectionCached.setStart(KTextEditor::Cursor::invalid());
- }
-
--bool KateViewInternal::isUserSelecting() const
--{
-- return m_selChangedByUser;
--}
--
- KateLayoutCache *KateViewInternal::cache() const
- {
- return m_layoutCache;
-diff --git a/src/view/kateviewinternal.h b/src/view/kateviewinternal.h
-index 66b137b6..8639dcef 100644
---- a/src/view/kateviewinternal.h
-+++ b/src/view/kateviewinternal.h
-@@ -228,8 +228,6 @@ public:
- return m_leftBorder;
- }
-
-- bool isUserSelecting() const;
--
- // EVENT HANDLING STUFF - IMPORTANT
- private:
- void fixDropEvent(QDropEvent *event);
---
-GitLab
-
diff --git a/kde-frameworks/ktexteditor/ktexteditor-5.90.0-r2.ebuild b/kde-frameworks/ktexteditor/ktexteditor-5.90.0-r2.ebuild
deleted file mode 100644
index 3c7a77ac1c3a..000000000000
--- a/kde-frameworks/ktexteditor/ktexteditor-5.90.0-r2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PVCUT=$(ver_cut 1-2)
-QTMIN=5.15.2
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org
-
-DESCRIPTION="Framework providing a full text editor component"
-
-LICENSE="LGPL-2+"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-IUSE="+editorconfig"
-
-RESTRICT="test"
-
-DEPEND="
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtprintsupport-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- =kde-frameworks/karchive-${PVCUT}*:5
- =kde-frameworks/kauth-${PVCUT}*:5
- =kde-frameworks/kcodecs-${PVCUT}*:5
- =kde-frameworks/kcompletion-${PVCUT}*:5
- =kde-frameworks/kconfig-${PVCUT}*:5
- =kde-frameworks/kconfigwidgets-${PVCUT}*:5
- =kde-frameworks/kcoreaddons-${PVCUT}*:5
- =kde-frameworks/kguiaddons-${PVCUT}*:5
- =kde-frameworks/ki18n-${PVCUT}*:5
- =kde-frameworks/kiconthemes-${PVCUT}*:5
- =kde-frameworks/kio-${PVCUT}*:5
- =kde-frameworks/kitemviews-${PVCUT}*:5
- =kde-frameworks/kjobwidgets-${PVCUT}*:5
- =kde-frameworks/kparts-${PVCUT}*:5
- =kde-frameworks/ktextwidgets-${PVCUT}*:5
- =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
- =kde-frameworks/kxmlgui-${PVCUT}*:5
- =kde-frameworks/sonnet-${PVCUT}*:5
- =kde-frameworks/syntax-highlighting-${PVCUT}*:5
- editorconfig? ( app-text/editorconfig-core-c )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="test? ( >=kde-frameworks/kservice-${PVCUT}:5 )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-revert-5dce70a9.patch # KDE-bugs 446189, 447525
- "${FILESDIR}"/${P}-KDEBUG-447972.patch
- "${FILESDIR}"/${P}-CVE-2022-23853-{1,2}.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package editorconfig EditorConfig)
- )
-
- ecm_src_configure
-}