summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-12 10:13:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-13 23:25:51 +0200
commit1edaeb45f8c277a4086e56f4e7da0d4dddfa6c91 (patch)
tree559f69cc4565f7c59d4e7ac92cbab98a5fb86968 /kde-frameworks/kwallet
parentsys-kernel/gentoo-sources: Cleanup of the 4.12.X series (diff)
downloadgentoo-1edaeb45f8c277a4086e56f4e7da0d4dddfa6c91.tar.gz
gentoo-1edaeb45f8c277a4086e56f4e7da0d4dddfa6c91.tar.bz2
gentoo-1edaeb45f8c277a4086e56f4e7da0d4dddfa6c91.zip
kde-frameworks: Add KDE Frameworks 5.37
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.37.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index 34579e9ffb78..281e0841f953 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.34.0.tar.xz 303892 SHA256 e537d561b536802bd0d881638a6068d8383d1f2497e9ad85c5c596aa746be323 SHA512 19a3a6e8f77e0a566befba7bc72ecdc7b870773944176247b53af312b475a0a00fbd5403cef8de6393cf8261c43627c947084231201a51074b8955ffe5989568 WHIRLPOOL 5e25beef155f3e167a26e6cda9d17c2f0ae3b95e7a04032c20e8af35ac8b252b06d6efa7f3cef9761cc319f985591fa79844cc5567fe4b2c1a38c3be0116fbef
DIST kwallet-5.36.0.tar.xz 303684 SHA256 8782caeb8d75da67a84c8eddf1d28af19fb01ffc0bbf7a35c0240e22519ccabb SHA512 42b6e24ee83d246bdec92c752750b69bec98598c22b939f1a7f40a14b386ee1002a1af8e249f218d67f3ebbe44222ec4f639b8d5aa78dc39b01c4dd5e9018a54 WHIRLPOOL 0049fe6926f9c5f614fbefcfbea7a95dae15d3f5acb5b22adb35b98f9a17320dc9157d6a80acb5a6ee9b03a20cff1094eb4749b9faa7d7ae8513111a54f9894b
+DIST kwallet-5.37.0.tar.xz 303728 SHA256 5fc368410da498dcd9eb9d5b7119f37c87f3a6b9859bbb2ce4a2ff0cfca0f2d0 SHA512 2b15caca7459e367f07d2aad98859db08f9e6bd337348ab63abd671dc45a434bf305e18e044b469a981c12661ce4dac2407af8b2dac7c3d0588a7b6f907548af WHIRLPOOL 71b238d749faf13e22a98a6763591fd51d708c92fc5ac329b1c1ec7c550c0efa2b8c0175c6be90c145331f6d1679b1d04c1faa37bad212c5be57e505d1edcf77
diff --git a/kde-frameworks/kwallet/kwallet-5.37.0.ebuild b/kde-frameworks/kwallet/kwallet-5.37.0.ebuild
new file mode 100644
index 000000000000..8037d189d022
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.37.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gpg +man"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/libgcrypt:0=
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gpg Gpgmepp)
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ if ! has_version "kde-plasma/kwallet-pam" || ! has_version "kde-apps/kwalletmanager:5" ; then
+ elog
+ elog "Install kde-plasma/kwallet-pam for auto-unlocking after account login."
+ elog "Install kde-apps/kwalletmanager:5 to manage your kwallet."
+ elog
+ fi
+ if has_version "kde-apps/kwalletd"; then
+ elog "Starting with 5.34.0-r1, ${PN} is able to serve applications"
+ elog "that still require old kwalletd4. After migration has finished,"
+ elog "kde-apps/kwalletd can be removed."
+ fi
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+}