summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-10 01:19:43 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-10 10:58:35 +0200
commit3a433556dffc41d462cbce30e8a5c097e9f73d2f (patch)
tree4fed51d583dd7dc07364b58a762fb1fd2732177b /kde-frameworks/kwallet
parentmedia-libs/libkate: Drop 0.4.1-r2 (diff)
downloadgentoo-3a433556dffc41d462cbce30e8a5c097e9f73d2f.tar.gz
gentoo-3a433556dffc41d462cbce30e8a5c097e9f73d2f.tar.bz2
gentoo-3a433556dffc41d462cbce30e8a5c097e9f73d2f.zip
kde-frameworks: Add KDE Frameworks 5.47.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.47.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index 0fde35f5092e..a46f7cb1ebbe 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.43.0.tar.xz 306848 BLAKE2B fbeac0ae4df91dde98840c3c88da30d43ce7ffa0fb4f18a5d51f0d15921d613804b235b0aba81c113ade1faba979ce105eaba956fcb9958a092925afc589d133 SHA512 38d129c45b1c2282c1e09a01fc9316b30b0d3f3c53f1b56dba295f732a2aaf5dab7759ca40b46ec80985d773a59a4ecddfc6edbe7fca7beb59c3392dab44e13b
DIST kwallet-5.46.0.tar.xz 307032 BLAKE2B c579c28981ab90048e8ebeffce9d679914441c2bca7f4850f87f6c3fe5af218ebff5645eafb6d52497b54dadbefa5efc5e1f376d87df0775c834023ce8173614 SHA512 244c386d5739752fdc27a3ef9b5a5a90a529ab842e7337b8ef9c539781f230bfd0dac487cda370a75bd9a6c0eda52549c9dda0fd6a27b1d243b373b05cd57d46
+DIST kwallet-5.47.0.tar.xz 307012 BLAKE2B 006336fb109b1b8b666d074b59090924bacbd74dac05a33d74748dc6152b7dbd8c8e1bd926d8fd7bc96339d8cdd284965f7c6ba66343d1ffaa7db109bf9af558 SHA512 428982c812c9ebae53289bbef0b16243925783d2b34475228f5354e07e4d7ec35f1c3601ccfd65349493c892d37ae7c2b8ff72f79e2f683966bdee821f9b8413
diff --git a/kde-frameworks/kwallet/kwallet-5.47.0.ebuild b/kde-frameworks/kwallet/kwallet-5.47.0.ebuild
new file mode 100644
index 000000000000..9ebbc724defc
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.47.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gpg +man"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/libgcrypt:0=
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gpg Gpgmepp)
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ if ! has_version "kde-plasma/kwallet-pam" || ! has_version "kde-apps/kwalletmanager:5" ; then
+ elog
+ elog "Install kde-plasma/kwallet-pam for auto-unlocking after account login."
+ elog "Install kde-apps/kwalletmanager:5 to manage your kwallet."
+ elog
+ fi
+ if has_version "kde-apps/kwalletd"; then
+ elog "Starting with 5.34.0-r1, ${PN} is able to serve applications"
+ elog "that still require old kwalletd4. After migration has finished,"
+ elog "kde-apps/kwalletd can be removed."
+ fi
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+}