summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-14 17:05:21 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-14 17:06:15 +0200
commit66b09c22973a2fa441b3a4dc7d71874a8a40204a (patch)
tree2bf2d57a052b373529fd4653fbcbbe51c3095d80 /kde-frameworks/kwallet
parentmedia-libs/oyranos: Drop old (diff)
downloadgentoo-66b09c22973a2fa441b3a4dc7d71874a8a40204a.tar.gz
gentoo-66b09c22973a2fa441b3a4dc7d71874a8a40204a.tar.bz2
gentoo-66b09c22973a2fa441b3a4dc7d71874a8a40204a.zip
kde-frameworks: Add KDE Frameworks 5.39.0
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.39.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index da518adc83e0..62b3041e4fc7 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.37.0.tar.xz 303728 SHA256 5fc368410da498dcd9eb9d5b7119f37c87f3a6b9859bbb2ce4a2ff0cfca0f2d0 SHA512 2b15caca7459e367f07d2aad98859db08f9e6bd337348ab63abd671dc45a434bf305e18e044b469a981c12661ce4dac2407af8b2dac7c3d0588a7b6f907548af WHIRLPOOL 71b238d749faf13e22a98a6763591fd51d708c92fc5ac329b1c1ec7c550c0efa2b8c0175c6be90c145331f6d1679b1d04c1faa37bad212c5be57e505d1edcf77
DIST kwallet-5.38.0.tar.xz 303756 SHA256 dc06fe8917cf5ea61251e42e9c7e9e5662eb223aace1bf8ee4becf6a896cdae3 SHA512 e66266015c674a7ba731fc5c37fe2bed1edf18645393793b6dfa552dcc1fb93227db73913503961f46d72c5c71b11c807d61a1bb0980f5ac1d62bab59efa72db WHIRLPOOL ef012950f779d127146f149ce8bc2c9c452583bc29b0add296fe516102ac9bd258dd794a2eacc28e794201ae6b385ff0ac2c522217893db78bc473e94c51526f
+DIST kwallet-5.39.0.tar.xz 303784 SHA256 5f83a5ca245773abfe5b31c536996ca1aee312d512181d133edcd890874f9fee SHA512 b8fef894a492a27691ae37199b9e564094bc3f2e342458ea97bac415148abd4b85018f1ec201e61bd28460909bbb719de30b7786dd1d954018a4f6f1a3ad28bf WHIRLPOOL 5682d326594f31f82dca239de12569787124046751f741bea4449f6938bcd46944f53462c201e0399f48b6cad9741b389c1faa03f5737719f5d205e9163cc47d
diff --git a/kde-frameworks/kwallet/kwallet-5.39.0.ebuild b/kde-frameworks/kwallet/kwallet-5.39.0.ebuild
new file mode 100644
index 000000000000..8037d189d022
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.39.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gpg +man"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/libgcrypt:0=
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gpg Gpgmepp)
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ if ! has_version "kde-plasma/kwallet-pam" || ! has_version "kde-apps/kwalletmanager:5" ; then
+ elog
+ elog "Install kde-plasma/kwallet-pam for auto-unlocking after account login."
+ elog "Install kde-apps/kwalletmanager:5 to manage your kwallet."
+ elog
+ fi
+ if has_version "kde-apps/kwalletd"; then
+ elog "Starting with 5.34.0-r1, ${PN} is able to serve applications"
+ elog "that still require old kwalletd4. After migration has finished,"
+ elog "kde-apps/kwalletd can be removed."
+ fi
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+}