summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-10 18:45:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-11 22:46:38 +0200
commit0c9474011d8d2aeba1e13f471e9dad1e5e00f153 (patch)
tree37d1ce428db1a7955cf06e9ba653f9bfd865740b /kde-frameworks/purpose
parentkde-frameworks/plasma: 5.84.0 version bump (diff)
downloadgentoo-0c9474011d8d2aeba1e13f471e9dad1e5e00f153.tar.gz
gentoo-0c9474011d8d2aeba1e13f471e9dad1e5e00f153.tar.bz2
gentoo-0c9474011d8d2aeba1e13f471e9dad1e5e00f153.zip
kde-frameworks/purpose: 5.84.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.84.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 15fb06037de2..2249ffd96bd2 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.82.0.tar.xz 159860 BLAKE2B f29c436239b13c5c025b990a0bdda00107f947dda44b56546049a6e1341f5ca35592c5a4626d62c9ce15b914e566b9a4c96852f0ff9b22d6a22b07b744e1e5f6 SHA512 bccb2cb1ceec619eb61d27cfd027ed20e824a2ba627120581dd928bb331cc1dfc416b5f8067aa31b2a9166dca937a180efc094107a4585e590a5bd9eceec21a5
DIST purpose-5.83.0.tar.xz 159896 BLAKE2B db631013b796163d05935374e80829bce68b6a626570a8e5bbb805169dbf1a2a84ec95f34117db91dcf62b1d78d8a0d5162f9d34a94a03b3f333f29eb354b31f SHA512 3e7c562e5bf545fd766ab63dff6d4a91b587c83676582349a8a7a433f93898fa94ff53df57eae1746ddc5139124541d97edbcef71a28ed3215d5f0bd31f0c8ed
+DIST purpose-5.84.0.tar.xz 159972 BLAKE2B 034270e38474dbace3e556e86e1649aee590bf847b2a40fd1e82be9ef3da270f86f8e6bef3d4ffdb56bfafd719a28f316b3c3749fd1e540e5bd52e9335ba9e3b SHA512 1323ad30d7cddd04ada06c1bbee5ca8217173710d93a989b952c8ce4790aa7c6f3fbaf04b75cf56834d0e2867674c6296adeeb21c0b5c172c06eb257908000fd
diff --git a/kde-frameworks/purpose/purpose-5.84.0.ebuild b/kde-frameworks/purpose/purpose-5.84.0.ebuild
new file mode 100644
index 000000000000..0dc933045ffd
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.84.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT+=" test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}