summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-12 22:52:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-13 07:18:45 +0200
commit5787ed46afe6c742b37804448b1321651bb522bc (patch)
treea440cc29520edbbbe5814039e972350eea866687 /kde-frameworks/sonnet
parentkde-frameworks/solid: 5.86.0 version bump (diff)
downloadgentoo-5787ed46afe6c742b37804448b1321651bb522bc.tar.gz
gentoo-5787ed46afe6c742b37804448b1321651bb522bc.tar.bz2
gentoo-5787ed46afe6c742b37804448b1321651bb522bc.zip
kde-frameworks/sonnet: 5.86.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.86.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 7238eb862b01..7d47602c5a08 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1,2 +1,3 @@
DIST sonnet-5.82.0.tar.xz 293844 BLAKE2B 6e2c4558957d845a281955c63de7dd87fc21634a4cb3e89af47345da070b1dc15e91c558a865e0c7ac5e2adb2454d36b6b8f2f521112b4fd07ad1b2ad02f6c04 SHA512 3bc876b1e06ba5c08c05ce74530a2584b9853e8c9742f66b19529e7f78f3aad89d3a72e0a615e912d1cfd7a24b3de3a9068d0f72dce3c51ca03b896eeedde817
DIST sonnet-5.85.0.tar.xz 297068 BLAKE2B 7f5bad0ebe851443dd2150be3784442008ffd7ad7acdacb42d0f3495490477a1f570a0aec6dd1b600ca01a5f9fa13c87f56cceb50c98cc2ab399ce85bc04c369 SHA512 50ed8787a8c7378574376ef0539b211eafb349f139fabe6d22788af91d57e758c994ddfdf72d83d76009570dbc8dd4bcb3df3add5c9dc17347b9263e09969930
+DIST sonnet-5.86.0.tar.xz 297144 BLAKE2B f85e898cafdf3c45544c73c9a6867a344de6000ef884a18feab6113bbc1d4cba410fc7e32d2e6559ce17ac2bd1c1d084f0fcfd0c6368bc2a9f2cf5e7d68e3276 SHA512 11d9a736180868fbe79c66cfeaddbcb9b24f3dc33387520536ce24de5a2fcd4e0a205b0bbb74d8c143e923a17d4872fb70945072c960ae04e580e3ed1dab3711
diff --git a/kde-frameworks/sonnet/sonnet-5.86.0.ebuild b/kde-frameworks/sonnet/sonnet-5.86.0.ebuild
new file mode 100644
index 000000000000..dfbc16b70395
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.86.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # sonnet-test_settings: bug 680032
+ # sonnet-test_autodetect: bug 779994
+ local myctestargs=(
+ -E "(sonnet-test_autodetect|sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ ecm_src_test
+}