summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-14 13:46:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-14 13:46:10 +0200
commit82d39affe7c0394f58b7dbda11a4df2d233e86d1 (patch)
tree0c87d649221962703f877bfcae356c45a4d72b6c /kde-frameworks/sonnet
parentkde-apps/kde-dev-utils: Fix build with KF-5.48 (diff)
downloadgentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.tar.gz
gentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.tar.bz2
gentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.zip
kde-frameworks: Add KDE Frameworks 5.48
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.48.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index a6cefe3d7413..9788853e7e71 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1,2 +1,3 @@
DIST sonnet-5.46.0.tar.xz 286760 BLAKE2B 646dabdd56f405ea521aa7011057d03ec45e1d2902b15ef992ccc285dccf457d8f8dcd7c64a13f67b0dab486a06bfa817081dd5536fa8e6a880a34e7d22068ed SHA512 537a103ae6a15b9f94e317f396bcd3dd791715e596ac094dfaf88fb48e7eca682481fc8b040cc405c0db740d2c1c3edc9b73e96a0ad47925a4a8b6dbf9682880
DIST sonnet-5.47.0.tar.xz 285848 BLAKE2B d5c58e37216228ee93a0ac1466a85518df15124d929a516964bb844204f89571ec81df6bd88cd876767580ea5ec7228feb41a549168d074aed7e498cead3df12 SHA512 e004c0fbf9d2750b4e9f4b093c499312d04cd3d507313dcf35f495552031016fa9f45a7e38476baf720e15bf654de5ccab8c534cbe9e414496d4f9b500ebb332
+DIST sonnet-5.48.0.tar.xz 286072 BLAKE2B c184c9d7a356c3ae4f06cf783b007fec6e701beb14ab1c6c447040bc3c9d0d75327f0cf9c4939db9e1ba33c8037ddd92d25f76feca0e4e8b50e42747404386f4 SHA512 70fdcdad762b1418b2a22100451d2609e698fcd436f975faeea53b2615e946a886eaa44d88e1ad6e0f4df73f3d1ef022fc5f32715ced8e03ab11791a80c92f8a
diff --git a/kde-frameworks/sonnet/sonnet-5.48.0.ebuild b/kde-frameworks/sonnet/sonnet-5.48.0.ebuild
new file mode 100644
index 000000000000..c71996ffd9f6
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.48.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}