summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-08-12 23:43:45 +1000
committerMichael Palimaka <kensington@gentoo.org>2015-08-12 23:45:30 +1000
commita9defc7f348c2dcb71591311e3b74e00e1f5014b (patch)
treeeee9ed6a276b5d1711e681571d186010b661bc86 /kde-frameworks/sonnet
parentprofiles: mask kde-frameworks/kauth[policykit] on x86 due to unkeyworded depe... (diff)
downloadgentoo-a9defc7f348c2dcb71591311e3b74e00e1f5014b.tar.gz
gentoo-a9defc7f348c2dcb71591311e3b74e00e1f5014b.tar.bz2
gentoo-a9defc7f348c2dcb71591311e3b74e00e1f5014b.zip
kde-frameworks: add 5.13.0
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.13.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index b0e575057a2a..603a2f12dbb5 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1 +1,2 @@
DIST sonnet-5.12.0.tar.xz 274688 SHA256 345446f795c9d63c24a93c56424f2a7a40c0376b6556a62872f51c92f46a25e7 SHA512 1214507298ae9f9d61b50c6d873d7f8b280dd4629e73547574329fa52f3f31fefa6c87b6405f74dc17af3caa5eef4d768a3acf2a26ecb1cdc9459feda8a4e374 WHIRLPOOL bc8505d6f2ae1b3e19d5728594a1981aa88464a2738ea996185a344cb222968a24324e09a0ab4211a1df00a0089d95055bff17574113aa46dcb4521a1c28374e
+DIST sonnet-5.13.0.tar.xz 277428 SHA256 a7743a3c36b6cd27c008d4a7bf8062e4ac59a4d32e6a2e33139e19ac444c4716 SHA512 3f23622f3c4a23c244b1361c8bd495be8bc9dcc6ab4a8ecbb9953fbab9f9b372a2250f7acbaadb17421c3fafd88b7eb2c8f5f626db0aefc96ac4d60b22d70b3a WHIRLPOOL 53d4be86f8b7196221e450e0ea76a5149dc003ebacd5a04d6b25bc89192c6e0246d06dc852325a92d06668cdc0911e645fc3302271fc53b18b4ff8d891e98152
diff --git a/kde-frameworks/sonnet/sonnet-5.13.0.ebuild b/kde-frameworks/sonnet/sonnet-5.13.0.ebuild
new file mode 100644
index 000000000000..167ffd7060d8
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.13.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking capabilities through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="+aspell hunspell nls"
+
+RDEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )
+"
+DEPEND="${RDEPEND}
+ nls? ( dev-qt/linguist-tools:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell)
+ $(cmake-utils_use_find_package hunspell)
+ )
+
+ kde5_src_configure
+}