summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-09-10 13:23:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-09-10 13:43:44 +0200
commit0c4e3ab6e387bc4f12a6c7edb19961f0795940cd (patch)
tree23e5934ffe1150d743ca8c9bfbca7be34a5c9947 /kde-frameworks
parentkde-frameworks/kactivities: 5.110.0 version bump (diff)
downloadgentoo-0c4e3ab6e387bc4f12a6c7edb19961f0795940cd.tar.gz
gentoo-0c4e3ab6e387bc4f12a6c7edb19961f0795940cd.tar.bz2
gentoo-0c4e3ab6e387bc4f12a6c7edb19961f0795940cd.zip
kde-frameworks/kauth: 5.110.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.110.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index c60dd93426cd..c1ab8fc6b183 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1,2 +1,3 @@
DIST kauth-5.108.0.tar.xz 2307472 BLAKE2B d75d8c20720fc9f09fafa1e88d643463b0e181696625fad5cfff54b086a40c432a61d980b942b286d533c7f3d24a1dd06c5213b2603682716c961e4083b71324 SHA512 c89d0bfcefa0ec0e81aed7b23dafdcdc36dc380cad63c5ea156030cab62014b980fafa5caf72e7ebb556c33e164f9edcb8c6a577d3d8fef9cfce01929434c449
DIST kauth-5.109.0.tar.xz 2307448 BLAKE2B 6281117efb30d5af1a889f319be4f8f63e5319abf1131049d9d281c7942fa2e7f45cd19d70b741f0f4b00b5e35e0f895c0de520e9dfed54fc51b7f10367441f3 SHA512 a588feb84a9f19a224daf856c63f94a52ae382390230f7264a486645763f4cec09c299cd7301b3a7ec050080982aeb4a60c02446ae35015391c51a8048e744d1
+DIST kauth-5.110.0.tar.xz 2307544 BLAKE2B 885f3f336b94d762b078e236832b97586c3e38d203d32c9c4486b4d4d085a3cc27b6048acd6da13b903d65e94652963c3ea775b9a4e04d038bf3d032245e6d5a SHA512 c4dc73202208e567af9e34ccdbeb58a6eabe72f9d6c98b4c0e17a0f67bbdf5c4571f4a44a15b765deda68739d7943710cf2f12270cba55bf511cfe4ddeef076a
diff --git a/kde-frameworks/kauth/kauth-5.110.0.ebuild b/kde-frameworks/kauth/kauth-5.110.0.ebuild
new file mode 100644
index 000000000000..e9a66cdb7c42
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.110.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="+policykit"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ policykit? ( >=sys-auth/polkit-qt-0.113.0[qt5(+)] )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package policykit PolkitQt5-1)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ ecm_src_test
+}