summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-08-13 19:43:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-14 10:29:16 +0200
commit108478bae2171cdc105e311655dc2cf62f8efdd8 (patch)
tree0121f45681d2c8486ed26381ead206c720ce005c /kde-frameworks
parentkde-frameworks/kcrash: 5.97.0 version bump (diff)
downloadgentoo-108478bae2171cdc105e311655dc2cf62f8efdd8.tar.gz
gentoo-108478bae2171cdc105e311655dc2cf62f8efdd8.tar.bz2
gentoo-108478bae2171cdc105e311655dc2cf62f8efdd8.zip
kde-frameworks/kdoctools: 5.97.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kdoctools/Manifest1
-rw-r--r--kde-frameworks/kdoctools/kdoctools-5.97.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-frameworks/kdoctools/Manifest b/kde-frameworks/kdoctools/Manifest
index ddb59893ed59..34fd64587bb7 100644
--- a/kde-frameworks/kdoctools/Manifest
+++ b/kde-frameworks/kdoctools/Manifest
@@ -1 +1,2 @@
DIST kdoctools-5.96.0.tar.xz 440328 BLAKE2B ed7672eacd056ffc81ed334313f8beaf45dfd1efbd96721ae5b2f6aa7c734dd4bf7b2f304c1ffefa4abd0a88c4e950eed6f736df61808a691d979589b7e0157c SHA512 cf0dea4b872513a1b79db6b4c7b58b56e5c73267cd89668e843ea10ecb3c544614bb22d1af9739436d192805a8f643d9e51374034f529c6be4fb518741f6eaa7
+DIST kdoctools-5.97.0.tar.xz 440780 BLAKE2B 056dbff1a4ef5a0236bd23cf1befbcd13f37af702860c78353d66b57711a2b7ea969b68d2fe8334a61f299ba382c512a313dba8ebf43d89e149b824af9d9985f SHA512 5ef770cf0b3fbe1e9703932786bc2b49e4d6f18a0821f6829e0bdc5556652a4bfdc9600a3ad48303da4ffd9839ab38fa9aecbb993e9b55e4f487c2060efcf565
diff --git a/kde-frameworks/kdoctools/kdoctools-5.97.0.ebuild b/kde-frameworks/kdoctools/kdoctools-5.97.0.ebuild
new file mode 100644
index 000000000000..fe72dddcecef
--- /dev/null
+++ b/kde-frameworks/kdoctools/kdoctools-5.97.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Tools to generate documentation in various formats from DocBook files"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ dev-perl/URI
+ nls? ( >=kde-frameworks/ki18n-${PVCUT}:5 )
+"
+DEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ app-text/sgml-common
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ =kde-frameworks/karchive-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.54.0-gentoo-docbundledir.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package nls KF5I18n)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # bug 665622
+ local myctestargs=(
+ -E "(kdoctools_install)"
+ )
+
+ ecm_src_test
+}