summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-10 09:20:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-10 10:10:57 +0100
commit448ebc67b241e315aaf6b7f1f422a6993a204b94 (patch)
tree3af8d73121c1de5429980bb35a47f87fbe593115 /kde-frameworks
parentkde-frameworks/kglobalaccel: drop 5.88.0* (diff)
downloadgentoo-448ebc67b241e315aaf6b7f1f422a6993a204b94.tar.gz
gentoo-448ebc67b241e315aaf6b7f1f422a6993a204b94.tar.bz2
gentoo-448ebc67b241e315aaf6b7f1f422a6993a204b94.zip
kde-frameworks/kiconthemes: drop 5.88.0*
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kiconthemes/Manifest1
-rw-r--r--kde-frameworks/kiconthemes/files/kiconthemes-5.88.0-fix-icon-preference.patch122
-rw-r--r--kde-frameworks/kiconthemes/kiconthemes-5.88.0-r1.ebuild34
3 files changed, 0 insertions, 157 deletions
diff --git a/kde-frameworks/kiconthemes/Manifest b/kde-frameworks/kiconthemes/Manifest
index bd16752e21fd..bc176393a03b 100644
--- a/kde-frameworks/kiconthemes/Manifest
+++ b/kde-frameworks/kiconthemes/Manifest
@@ -1,2 +1 @@
-DIST kiconthemes-5.88.0.tar.xz 223284 BLAKE2B 374935539c45468dd60364701ad2ca9ba1b7bc5852692a4299d74efd99fe615913626e42525deeebc5ea27ae44aab7795ffbaefa2978f3a214c3a3359e1cc664 SHA512 56bb3da876cfe7bc4999730ae91c9e71001aff63c904c4bdeb5989b6465c981b848af36942a5a5979e08af0b654c9e403210b037cab7b085d14281ed769650c9
DIST kiconthemes-5.90.0.tar.xz 225884 BLAKE2B 9697b1cda2520807b6b21e9210a6e436cfa9cbba25ce3a05c339c94dacf1687700d8ed59c806e222e811df166856217b5080d311a44eedf375b252e048bb7d64 SHA512 91a281df7c0336b1358969d0c6ef2899679e1b0088d74f5ad5c02ddcc9d0e0bfc71ea6fe13eec6ba6668996128ef6d175b94ae46388327534a28f851eae99998
diff --git a/kde-frameworks/kiconthemes/files/kiconthemes-5.88.0-fix-icon-preference.patch b/kde-frameworks/kiconthemes/files/kiconthemes-5.88.0-fix-icon-preference.patch
deleted file mode 100644
index e8b48b468323..000000000000
--- a/kde-frameworks/kiconthemes/files/kiconthemes-5.88.0-fix-icon-preference.patch
+++ /dev/null
@@ -1,122 +0,0 @@
-From 13181b03eac3c85f0649d5399d8c3037c388928c Mon Sep 17 00:00:00 2001
-From: Jan Blackquill <uhhadd@gmail.com>
-Date: Thu, 25 Nov 2021 14:51:06 -0500
-Subject: [PATCH] KIconLoader: prefer icons from current theme before falling
- back to other themes
-
-BUG: 445804
----
- autotests/kiconloader_unittest.cpp | 25 ++++++++++++++++++++++
- src/kiconloader.cpp | 34 ++++++------------------------
- 2 files changed, 32 insertions(+), 27 deletions(-)
-
-diff --git a/autotests/kiconloader_unittest.cpp b/autotests/kiconloader_unittest.cpp
-index 813215d..c232111 100644
---- a/autotests/kiconloader_unittest.cpp
-+++ b/autotests/kiconloader_unittest.cpp
-@@ -112,6 +112,12 @@ private Q_SLOTS:
- QVERIFY(QFile::copy(QStringLiteral(":/test-22x22.png"), testIconsDir.filePath(QStringLiteral("breeze/22x22/mimetypes/unknown.png"))));
- QVERIFY(QFile::copy(QStringLiteral(":/coloredsvgicon.svg"), testIconsDir.filePath(QStringLiteral("breeze/22x22/apps/coloredsvgicon.svg"))));
-
-+ // prepare some icons for our actions test
-+ // when querying breeze for 'one-two', we expect
-+ // 'one' from breeze instead of oxygen's 'one-two'.
-+ QVERIFY(QFile::copy(QStringLiteral(":/test-22x22.png"), testIconsDir.filePath(QStringLiteral("oxygen/22x22/actions/one-two.png"))));
-+ QVERIFY(QFile::copy(QStringLiteral(":/test-22x22.png"), testIconsDir.filePath(QStringLiteral("breeze/22x22/actions/one.png"))));
-+
- QVERIFY(QFile::setPermissions(breezeThemeFile, QFileDevice::ReadOwner | QFileDevice::WriteOwner));
- KConfig configFile(breezeThemeFile);
- KConfigGroup iconThemeGroup = configFile.group("Icon Theme");
-@@ -332,6 +338,25 @@ private Q_SLOTS:
- QVERIFY(QFile::exists(unknownPath));
- }
-
-+ void testCorrectFallback()
-+ {
-+ // we want to prefer icons from the same theme
-+
-+ // so if we have something like:
-+ /*
-+ oxygen:
-+ one-two
-+
-+ breeze:
-+ one
-+ */
-+ // and we ask for 'one-two', we expect to see 'one' from breeze instead
-+ // of 'one-two' from oxygen.
-+ QString path;
-+ KIconLoader::global()->loadIcon(QStringLiteral("one-two"), KIconLoader::Desktop, 24, KIconLoader::DefaultState, QStringList(), &path);
-+ QVERIFY(path.contains("breeze/22x22/actions"));
-+ }
-+
- void testPathStore()
- {
- QString path;
-diff --git a/src/kiconloader.cpp b/src/kiconloader.cpp
-index 4d4181d..8a644d4 100644
---- a/src/kiconloader.cpp
-+++ b/src/kiconloader.cpp
-@@ -1021,12 +1021,7 @@ QString KIconLoaderPrivate::findMatchingIcon(const QString &name, int size, qrea
- {
- const_cast<KIconLoaderPrivate *>(this)->initIconThemes();
-
-- // Do two passes through themeNodes.
-- //
-- // The first pass looks for an exact match in each themeNode one after the other.
-- // If one is found and it is an app icon then return that icon.
-- //
-- // In the next pass (assuming the first pass failed), it looks for
-+ // This looks for the exact match and its
- // generic fallbacks in each themeNode one after the other.
-
- // In theory we should only do this for mimetype icons, not for app icons,
-@@ -1036,22 +1031,17 @@ QString KIconLoaderPrivate::findMatchingIcon(const QString &name, int size, qrea
- // Once everyone uses that to look up mimetype icons, we can kill the fallback code
- // from this method.
-
-- for (KIconThemeNode *themeNode : std::as_const(links)) {
-- const QString path = themeNode->theme->iconPathByName(name, size, KIconLoader::MatchBest, scale);
-- if (!path.isEmpty()) {
-- return path;
-- }
-- }
--
-- if (name.endsWith(QLatin1String("-x-generic"))) {
-- return QString(); // no further fallback
-- }
-- bool genericFallback = false;
-+ bool genericFallback = name.endsWith(QLatin1String("-x-generic"));;
- QString path;
- for (KIconThemeNode *themeNode : std::as_const(links)) {
- QString currentName = name;
-
- while (!currentName.isEmpty()) {
-+ path = themeNode->theme->iconPathByName(currentName, size, KIconLoader::MatchBest, scale);
-+ if (!path.isEmpty()) {
-+ return path;
-+ }
-+
- if (genericFallback) {
- // we already tested the base name
- break;
-@@ -1088,16 +1078,6 @@ QString KIconLoaderPrivate::findMatchingIcon(const QString &name, int size, qrea
- break;
- }
- }
--
-- if (currentName.isEmpty()) {
-- break;
-- }
--
-- // qCDebug(KICONTHEMES) << "Looking up" << currentName;
-- path = themeNode->theme->iconPathByName(currentName, size, KIconLoader::MatchBest, scale);
-- if (!path.isEmpty()) {
-- return path;
-- }
- }
- }
-
---
-GitLab
-
diff --git a/kde-frameworks/kiconthemes/kiconthemes-5.88.0-r1.ebuild b/kde-frameworks/kiconthemes/kiconthemes-5.88.0-r1.ebuild
deleted file mode 100644
index 810f917fbbf5..000000000000
--- a/kde-frameworks/kiconthemes/kiconthemes-5.88.0-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_DESIGNERPLUGIN="true"
-PVCUT=$(ver_cut 1-2)
-QTMIN=5.15.2
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org
-
-DESCRIPTION="Framework for icon theming and configuration"
-LICENSE="LGPL-2+"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-IUSE=""
-
-RESTRICT="test" # bug 574770
-
-DEPEND="
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtsvg-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- =kde-frameworks/karchive-${PVCUT}*:5
- =kde-frameworks/kconfig-${PVCUT}*:5
- =kde-frameworks/kconfigwidgets-${PVCUT}*:5
- =kde-frameworks/kcoreaddons-${PVCUT}*:5
- =kde-frameworks/ki18n-${PVCUT}*:5
- =kde-frameworks/kitemviews-${PVCUT}*:5
- =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-fix-icon-preference.patch ) # KDE-bug 445804