summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-14 23:19:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-14 23:19:03 +0200
commit4b7d053f0d6dee004a42b4c148205a6e0b16910f (patch)
tree5efb482ad5ec3a858184c6bc409985feff54ecd2 /kde-frameworks
parentkde-frameworks/extra-cmake-modules: Drop 5.72.0 (r0) (diff)
downloadgentoo-4b7d053f0d6dee004a42b4c148205a6e0b16910f.tar.gz
gentoo-4b7d053f0d6dee004a42b4c148205a6e0b16910f.tar.bz2
gentoo-4b7d053f0d6dee004a42b4c148205a6e0b16910f.zip
kde-frameworks/krunner: Backport crashfix
See also: https://mail.kde.org/pipermail/kde-distro-packagers/2020-July/000427.html KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=423003 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/krunner/files/krunner-5.72.0-fix-vtable.patch54
-rw-r--r--kde-frameworks/krunner/krunner-5.72.0-r1.ebuild40
2 files changed, 94 insertions, 0 deletions
diff --git a/kde-frameworks/krunner/files/krunner-5.72.0-fix-vtable.patch b/kde-frameworks/krunner/files/krunner-5.72.0-fix-vtable.patch
new file mode 100644
index 000000000000..88f629721fca
--- /dev/null
+++ b/kde-frameworks/krunner/files/krunner-5.72.0-fix-vtable.patch
@@ -0,0 +1,54 @@
+From 8f7ce559b84ee0c21de0256e6591793e4b95f411 Mon Sep 17 00:00:00 2001
+From: David Redondo <kde@david-redondo.de>
+Date: Tue, 14 Jul 2020 13:02:51 +0200
+Subject: [PATCH] Do not remove virtual method from build
+
+Method was deprecated in fc5738ab7c4025a87e2bbd656914b6187df7a9eb. Removing the
+method when building without deprecated methods (for example the pim runner
+does this) changes the vtable leading to crashes.
+BUG: 423003
+---
+ src/abstractrunner.cpp | 2 --
+ src/abstractrunner.h | 2 --
+ 2 files changed, 4 deletions(-)
+
+diff --git a/src/abstractrunner.cpp b/src/abstractrunner.cpp
+index 378c73d..34c44d1 100644
+--- a/src/abstractrunner.cpp
++++ b/src/abstractrunner.cpp
+@@ -244,12 +244,10 @@ void AbstractRunner::setHasRunOptions(bool hasRunOptions)
+ }
+ #endif
+
+-#if KRUNNER_BUILD_DEPRECATED_SINCE(5, 71)
+ void AbstractRunner::createRunOptions(QWidget *parent)
+ {
+ Q_UNUSED(parent)
+ }
+-#endif
+
+ AbstractRunner::Speed AbstractRunner::speed() const
+ {
+diff --git a/src/abstractrunner.h b/src/abstractrunner.h
+index cb4e32a..ae9558d 100644
+--- a/src/abstractrunner.h
++++ b/src/abstractrunner.h
+@@ -161,7 +161,6 @@ class KRUNNER_EXPORT AbstractRunner : public QObject
+ bool hasRunOptions();
+ #endif
+
+-#if KRUNNER_ENABLE_DEPRECATED_SINCE(5, 71)
+ /**
+ * If hasRunOptions() returns true, this method may be called to get
+ * a widget displaying the options the user can interact with to modify
+@@ -172,7 +171,6 @@ class KRUNNER_EXPORT AbstractRunner : public QObject
+ */
+ KRUNNER_DEPRECATED_VERSION_BELATED(5, 71, 5, 0, "No longer use, feature removed")
+ virtual void createRunOptions(QWidget *widget);
+-#endif
+
+ /**
+ * Called whenever an exact or possible match associated with this
+--
+GitLab
+
diff --git a/kde-frameworks/krunner/krunner-5.72.0-r1.ebuild b/kde-frameworks/krunner/krunner-5.72.0-r1.ebuild
new file mode 100644
index 000000000000..4a7eb63b5416
--- /dev/null
+++ b/kde-frameworks/krunner/krunner-5.72.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for providing different actions given a string query"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/plasma-${PVCUT}*:5
+ =kde-frameworks/solid-${PVCUT}*:5
+ =kde-frameworks/threadweaver-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-vtable.patch" )
+
+src_test() {
+ # requires virtual dbus #630672
+ local myctestargs=(
+ -E "(dbusrunnertest)"
+ )
+ ecm_src_test
+}