summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-14 15:26:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-14 18:44:20 +0100
commita78e45c533669e879450ec2813f9c9ff3a7cfd69 (patch)
treee6cf7bd8d2fbc8de5e3749e9e0f213b418c29b60 /kde-frameworks
parentkde-frameworks/kauth: 5.76.0 version bump (diff)
downloadgentoo-a78e45c533669e879450ec2813f9c9ff3a7cfd69.tar.gz
gentoo-a78e45c533669e879450ec2813f9c9ff3a7cfd69.tar.bz2
gentoo-a78e45c533669e879450ec2813f9c9ff3a7cfd69.zip
kde-frameworks/kcompletion: 5.76.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kcompletion/Manifest1
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.76.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/Manifest b/kde-frameworks/kcompletion/Manifest
index fb659da5f72a..9e4c60bdebf4 100644
--- a/kde-frameworks/kcompletion/Manifest
+++ b/kde-frameworks/kcompletion/Manifest
@@ -1,2 +1,3 @@
DIST kcompletion-5.74.0.tar.xz 121524 BLAKE2B cc0c0b7f37cc781795e7db7d91d88728b0a62d85dd870f2967bb00f4a466dfcae7754921a4c2dcabc7200dfac51ee0ae7642b94fd338c5788a6346616618138b SHA512 d63bb7a1f4a2ed42888b3811328416d0a63ff3f9cd2fd64f836cbaaabcdd5a11847e26d00e96ab2794f08c02cbfd60a969caa53f9210c21c0a85a3ce688cdaba
DIST kcompletion-5.75.0.tar.xz 121432 BLAKE2B 8a5472400730f7ca981ca0821efe4c303fc8dc40ea31f09cdf88a0a9528d64a8828eae2d7d2e1dbd2010c1f4f1e89fb67a7de431160f07b4a358c57eea32fc3d SHA512 84d973d8b8dee7106fde69f944bc52a902fbaddc440bd4be5c01d2de4d0576fa849ab4ef4c583c7016e9a5e664c69e8ef4e8b68398e1dd453c9c2a3227bbfbbf
+DIST kcompletion-5.76.0.tar.xz 121464 BLAKE2B 458bb01686846287bb9d3ac41db08bda1dcc159786bcbdabdad057408970ae2aa74f9b26023e58db6b1e5b079f1b82465f224efd2d90be9ba013c4ecbf16154b SHA512 96d11749bd972109b9c635a7664d205515caf7a3426b26006659e6bc32511fdb3d90f1ec91d1071d567e8ab96883bddd16cf303401b94c1ab72cd9c658040f6e
diff --git a/kde-frameworks/kcompletion/kcompletion-5.76.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.76.0.ebuild
new file mode 100644
index 000000000000..280b3ee0bc3e
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.76.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ )
+ ecm_src_configure
+}