summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/kcaldav/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/kcaldav/files')
-rw-r--r--kde-misc/kcaldav/files/kcaldav-1.2.0-unbundle.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-misc/kcaldav/files/kcaldav-1.2.0-unbundle.patch b/kde-misc/kcaldav/files/kcaldav-1.2.0-unbundle.patch
new file mode 100644
index 000000000000..1d02dd9e364b
--- /dev/null
+++ b/kde-misc/kcaldav/files/kcaldav-1.2.0-unbundle.patch
@@ -0,0 +1,32 @@
+diff -urN kcaldav-1.2.0.orig/src/CMakeLists.txt kcaldav-1.2.0/src/CMakeLists.txt
+--- kcaldav-1.2.0.orig/src/CMakeLists.txt 2010-11-03 07:28:48.000000000 +0100
++++ kcaldav-1.2.0/src/CMakeLists.txt 2010-11-09 00:18:53.000000000 +0100
+@@ -3,6 +3,9 @@
+
+ project("kcaldav")
+
++find_package(PkgConfig)
++pkg_check_modules(CALDAV libcaldav REQUIRED)
++
+ find_package(KDE4 REQUIRED)
+ find_package(Qt4 REQUIRED)
+ include(KDE4Defaults)
+@@ -45,16 +48,13 @@
+
+ kde4_add_library(kcal_caldav SHARED ${kcal_caldav_LIB_SRCS})
+
+-# add imported target
+-add_library(kcaldav_caldav_lib STATIC IMPORTED)
+-# point the imported target at the real file
+-set_target_properties(kcaldav_caldav_lib PROPERTIES IMPORTED_LOCATION libcaldav.a)
++include_directories( ${CALDAV_INCLUDEDIR} ${CALDAV_INCLUDEDIR}/libcaldav-${CALDAV_VERSION} )
+
+ target_link_libraries(kcal_caldav
+ ${KDE4_KDECORE_LIBS}
+ ${KDEPIMLIBS_KCAL_LIBS}
+ ${KDEPIMLIBS_KRESOURCES_LIBS}
+- kcaldav_caldav_lib
++ -lcaldav
+ ${CURL_LIBRARIES}
+ ${GLIB2_LIBRARIES})
+