summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-04-10 20:43:21 +0200
committerJohannes Huber <johu@gentoo.org>2018-04-10 20:43:33 +0200
commit403144c366b8149bf3f3dfbc3919adcbf44ae56a (patch)
tree66031f6a28866025af2531f61c73d4ffefb5f371 /kde-misc/kdeconnect
parentdev-libs/ffcall: Drop old version 1.1¾ (diff)
downloadgentoo-403144c366b8149bf3f3dfbc3919adcbf44ae56a.tar.gz
gentoo-403144c366b8149bf3f3dfbc3919adcbf44ae56a.tar.bz2
gentoo-403144c366b8149bf3f3dfbc3919adcbf44ae56a.zip
kde-misc/kdeconnect: Fix build w/o wayland/handbook
Reported-by: email200202@yahoo.com Thanks-to: Andreas Sturmlechner <asturm@gentoo.org> Closes: https://bugs.gentoo.org/652888 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'kde-misc/kdeconnect')
-rw-r--r--kde-misc/kdeconnect/files/kdeconnect-1.3.0-no-wayland.patch13
-rw-r--r--kde-misc/kdeconnect/kdeconnect-1.3.0.ebuild8
2 files changed, 18 insertions, 3 deletions
diff --git a/kde-misc/kdeconnect/files/kdeconnect-1.3.0-no-wayland.patch b/kde-misc/kdeconnect/files/kdeconnect-1.3.0-no-wayland.patch
new file mode 100644
index 000000000000..a46c284a017d
--- /dev/null
+++ b/kde-misc/kdeconnect/files/kdeconnect-1.3.0-no-wayland.patch
@@ -0,0 +1,13 @@
+diff --git a/plugins/mousepad/CMakeLists.txt b/plugins/mousepad/CMakeLists.txt
+index ab9913ff..bfd52cd7 100644
+--- a/plugins/mousepad/CMakeLists.txt
++++ b/plugins/mousepad/CMakeLists.txt
+@@ -10,7 +10,7 @@ if (LibFakeKey_FOUND)
+ find_package(X11 REQUIRED)
+ find_package(Qt5 ${QT_MIN_VERSION} REQUIRED COMPONENTS X11Extras)
+ endif()
+-find_package(KF5 ${KF5_MIN_VERSION} COMPONENTS Wayland)
++find_package(KF5Wayland ${KF5_MIN_VERSION} QUIET)
+
+ set(HAVE_X11 ${LibFakeKey_FOUND})
+ set(HAVE_WAYLAND ${KF5Wayland_FOUND})
diff --git a/kde-misc/kdeconnect/kdeconnect-1.3.0.ebuild b/kde-misc/kdeconnect/kdeconnect-1.3.0.ebuild
index 824a32a6085e..b826ef6e3ba1 100644
--- a/kde-misc/kdeconnect/kdeconnect-1.3.0.ebuild
+++ b/kde-misc/kdeconnect/kdeconnect-1.3.0.ebuild
@@ -4,7 +4,7 @@
EAPI=6
FRAMEWORKS_MINIMAL="5.42.0"
-KDE_HANDBOOK="optional"
+KDE_HANDBOOK="forceoptional"
KDE_TEST="true"
KMNAME="${PN}-kde"
KDE_SELINUX_MODULE="${PN}"
@@ -55,12 +55,14 @@ RDEPEND="${DEPEND}
RESTRICT+=" test"
+PATCHES=( "${FILESDIR}/${P}-no-wayland.patch" )
+
src_prepare() {
+ kde5_src_prepare
+
sed \
-e 's#${LIBEXEC_INSTALL_DIR}#@KDE_INSTALL_FULL_LIBEXECDIR@#' \
-i daemon/kdeconnectd.desktop.cmake || die
-
- kde5_src_prepare
}
src_configure() {