summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-03 22:00:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-03 22:49:41 +0100
commita5cdd6fb20ed0ba02372aa8b8b0a1ee3a30d1793 (patch)
tree8d19ee34dc747dcbc308df4f8b3c50b454393751 /kde-misc/kimtoy/kimtoy-1.92_pre20190225.ebuild
parentnet-libs/libkvkontakte: Drop 5.0.0 (r0) (diff)
downloadgentoo-a5cdd6fb20ed0ba02372aa8b8b0a1ee3a30d1793.tar.gz
gentoo-a5cdd6fb20ed0ba02372aa8b8b0a1ee3a30d1793.tar.bz2
gentoo-a5cdd6fb20ed0ba02372aa8b8b0a1ee3a30d1793.zip
kde-misc/kimtoy: Add 1.92_pre20190225 snapshot, EAPI-7 bump
po subdir does not build in release anyway, so nothing of value is lost. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-misc/kimtoy/kimtoy-1.92_pre20190225.ebuild')
-rw-r--r--kde-misc/kimtoy/kimtoy-1.92_pre20190225.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/kde-misc/kimtoy/kimtoy-1.92_pre20190225.ebuild b/kde-misc/kimtoy/kimtoy-1.92_pre20190225.ebuild
new file mode 100644
index 000000000000..0efb2e94e073
--- /dev/null
+++ b/kde-misc/kimtoy/kimtoy-1.92_pre20190225.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="c8b3da65bfd289d0a0262aa673aa6b697022d4a3"
+inherit kde5
+
+DESCRIPTION="An input method frontend for Plasma"
+HOMEPAGE="https://www.linux-apps.com/content/show.php?content=140967"
+SRC_URI="https://github.com/KDE/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl scim semantic-desktop"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ app-i18n/ibus
+ dev-libs/glib:2
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/libpng:0=[apng]
+ x11-libs/libX11
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ scim? (
+ >=app-i18n/scim-1.4.9
+ dev-libs/dbus-c++
+ )
+ semantic-desktop? ( $(add_frameworks_dep kfilemetadata) )
+"
+RDEPEND="${DEPEND}
+ !kde-misc/kimtoy:4
+ >=app-i18n/fcitx-4.0
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ # bug 581736
+ cmake_comment_add_subdirectory po
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package scim SCIM)
+ $(cmake-utils_use_find_package scim DBusCXX)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+S="${WORKDIR}/${PN}-${COMMIT}"