summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-10-15 03:36:50 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-10-15 03:37:12 +1100
commit39e34c8964b2c613a8e36045d403737c0f9ca855 (patch)
tree9dde78e2f0a6d6aeeb1b4d6eb38d0e6b54b8d246 /kde-misc/kio-gdrive/kio-gdrive-1.0.3.ebuild
parentwww-client/seamonkey: bump to build from comm-esr45.4.0 for security (diff)
downloadgentoo-39e34c8964b2c613a8e36045d403737c0f9ca855.tar.gz
gentoo-39e34c8964b2c613a8e36045d403737c0f9ca855.tar.bz2
gentoo-39e34c8964b2c613a8e36045d403737c0f9ca855.zip
kde-misc/kio-gdrive: version bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-misc/kio-gdrive/kio-gdrive-1.0.3.ebuild')
-rw-r--r--kde-misc/kio-gdrive/kio-gdrive-1.0.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/kde-misc/kio-gdrive/kio-gdrive-1.0.3.ebuild b/kde-misc/kio-gdrive/kio-gdrive-1.0.3.ebuild
new file mode 100644
index 000000000000..b036d59bdaa9
--- /dev/null
+++ b/kde-misc/kio-gdrive/kio-gdrive-1.0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="optional"
+inherit kde5
+
+DESCRIPTION="KIO Slave for Google Drive service"
+HOMEPAGE="https://phabricator.kde.org/project/profile/72/"
+
+if [[ ${KDE_BUILD_TYPE} != live ]] ; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+IUSE="+dolphin"
+
+DOCS=( README.md )
+
+COMMON_DEPEND="
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtwidgets)
+ dev-libs/qtkeychain:=[qt5]
+ >=net-libs/libkgapi-5.3.1:5
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+"
+RDEPEND="${COMMON_DEPEND}
+ dolphin? ( $(add_kdeapps_dep dolphin) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOLPHIN_INTEGRATION=$(usex dolphin)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ einfo
+ einfo "Either click on 'Google Drive File Manager' in the application"
+ einfo "launcher or type 'gdrive:/' in dolphin's location bar."
+ einfo
+}