summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-07 11:29:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-07 11:30:15 +0200
commit3cfdd312f28d0dd9d2a22aae19fa1a8d1dbaf7be (patch)
treec493e5c6dd4a8564b7cd7259fd6975b8569a86ca /kde-misc/plasma-pass
parentnet-libs/signond: Drop bogus dependency (diff)
downloadgentoo-3cfdd312f28d0dd9d2a22aae19fa1a8d1dbaf7be.tar.gz
gentoo-3cfdd312f28d0dd9d2a22aae19fa1a8d1dbaf7be.tar.bz2
gentoo-3cfdd312f28d0dd9d2a22aae19fa1a8d1dbaf7be.zip
kde-misc/plasma-pass: Fix build with Qt 5.15
Closes: https://bugs.gentoo.org/727398 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-misc/plasma-pass')
-rw-r--r--kde-misc/plasma-pass/files/plasma-pass-1.1.0-qt-5.15.patch29
-rw-r--r--kde-misc/plasma-pass/plasma-pass-1.1.0.ebuild2
2 files changed, 31 insertions, 0 deletions
diff --git a/kde-misc/plasma-pass/files/plasma-pass-1.1.0-qt-5.15.patch b/kde-misc/plasma-pass/files/plasma-pass-1.1.0-qt-5.15.patch
new file mode 100644
index 000000000000..ea67cf18dd21
--- /dev/null
+++ b/kde-misc/plasma-pass/files/plasma-pass-1.1.0-qt-5.15.patch
@@ -0,0 +1,29 @@
+From 3fb633159ca4a1db166d5c54bbc025f71aba1652 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Daniel=20Vr=C3=A1til?= <dvratil@kde.org>
+Date: Thu, 9 Apr 2020 12:48:53 +0200
+Subject: Fix build against Qt 5.15
+
+* asturm 2020-06-07: Rebased for 1.1.0
+
+---
+ plugin/passwordfiltermodel.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/plugin/passwordfiltermodel.cpp b/plugin/passwordfiltermodel.cpp
+index e815797..2d323ad 100644
+--- a/plugin/passwordfiltermodel.cpp 2019-12-06 07:59:15.000000000 +0100
++++ b/plugin/passwordfiltermodel.cpp 2020-06-07 11:22:23.310950571 +0200
+@@ -79,7 +79,11 @@
+ Q_ASSERT(sender() == &mUpdateTimer);
+
+ mFilter = mUpdateTimer.property(newFilterProperty).toString();
++#if QT_VERSION < QT_VERSION_CHECK(5, 15, 0)
+ mParts = mFilter.splitRef(QLatin1Char('/'), QString::SkipEmptyParts);
++#else
++ mParts = mFilter.splitRef(QLatin1Char('/'), Qt::SkipEmptyParts);
++#endif
+ Q_EMIT passwordFilterChanged();
+ mSortingLookup.clear();
+ invalidate();
+--
+cgit v1.1
diff --git a/kde-misc/plasma-pass/plasma-pass-1.1.0.ebuild b/kde-misc/plasma-pass/plasma-pass-1.1.0.ebuild
index 39281fe41e45..8bc8f79a2cac 100644
--- a/kde-misc/plasma-pass/plasma-pass-1.1.0.ebuild
+++ b/kde-misc/plasma-pass/plasma-pass-1.1.0.ebuild
@@ -32,3 +32,5 @@ DEPEND="
RDEPEND="${DEPEND}
>=kde-frameworks/kirigami-${KFMIN}:5
"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.15.patch" )