summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-11-10 00:03:03 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-11-10 00:03:20 +1100
commitfc9eac2e7aef04411f8b8588ef1764350e367079 (patch)
tree728000858711753d377717b100228dbc0deb9008 /kde-misc/tellico/tellico-3.0.ebuild
parentdev-python/simpleeval: Version bump (diff)
downloadgentoo-fc9eac2e7aef04411f8b8588ef1764350e367079.tar.gz
gentoo-fc9eac2e7aef04411f8b8588ef1764350e367079.tar.bz2
gentoo-fc9eac2e7aef04411f8b8588ef1764350e367079.zip
kde-misc/tellico: version bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-misc/tellico/tellico-3.0.ebuild')
-rw-r--r--kde-misc/tellico/tellico-3.0.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/kde-misc/tellico/tellico-3.0.ebuild b/kde-misc/tellico/tellico-3.0.ebuild
new file mode 100644
index 000000000000..2b61d25f3dee
--- /dev/null
+++ b/kde-misc/tellico/tellico-3.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="A collection manager for the KDE environment"
+HOMEPAGE="http://tellico-project.org/"
+SRC_URI="http://tellico-project.org/files/${P}.tar.xz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug discid pdf scanner semantic-desktop taglib v4l xmp yaz"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_frameworks_dep sonnet)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/btparse
+ dev-libs/libxml2
+ dev-libs/libxslt
+ discid? ( media-libs/libdiscid )
+ pdf? ( app-text/poppler[qt5] )
+ scanner? ( $(add_kdeapps_dep libksane) )
+ semantic-desktop? ( $(add_frameworks_dep kfilemetadata) )
+ taglib? ( >=media-libs/taglib-1.5 )
+ v4l? ( >=media-libs/libv4l-0.8.3 )
+ xmp? ( >=media-libs/exempi-2 )
+ yaz? ( >=dev-libs/yaz-2:0 )
+ !kde-misc/tellico:4
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+# tests need network access
+RESTRICT="test"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Csv=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5Cddb=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libkcddb=ON
+ -DENABLE_WEBCAM=$(usex v4l)
+ $(cmake-utils_use_find_package discid DiscID)
+ $(cmake-utils_use_find_package pdf PopplerQt5)
+ $(cmake-utils_use_find_package scanner KF5Sane)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ $(cmake-utils_use_find_package taglib Taglib)
+ $(cmake-utils_use_find_package xmp Exempi)
+ $(cmake-utils_use_find_package yaz Yaz)
+ )
+
+ kde5_src_configure
+}