summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-03 16:32:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-03 17:17:51 +0200
commit337cf4eb4007d4c3e6c5488f5d61aa19ff79af99 (patch)
tree1bb7367a8edb7be4b813c35465ec98b71670ed99 /kde-misc/wacomtablet/wacomtablet-3.0.0.ebuild
parentmail-filter/amavisd-milter: fix amavisd dep in init script (diff)
downloadgentoo-337cf4eb4007d4c3e6c5488f5d61aa19ff79af99.tar.gz
gentoo-337cf4eb4007d4c3e6c5488f5d61aa19ff79af99.tar.bz2
gentoo-337cf4eb4007d4c3e6c5488f5d61aa19ff79af99.zip
kde-misc/wacomtablet: 3.0.0 version bump
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'kde-misc/wacomtablet/wacomtablet-3.0.0.ebuild')
-rw-r--r--kde-misc/wacomtablet/wacomtablet-3.0.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-misc/wacomtablet/wacomtablet-3.0.0.ebuild b/kde-misc/wacomtablet/wacomtablet-3.0.0.ebuild
new file mode 100644
index 000000000000..859c6790e540
--- /dev/null
+++ b/kde-misc/wacomtablet/wacomtablet-3.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KControl module for Wacom tablets"
+HOMEPAGE="https://www.linux-apps.com/content/show.php?action=content&content=114856"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ >=x11-drivers/xf86-input-wacom-0.20.0
+ x11-libs/libXi
+ x11-libs/libxcb
+"
+DEPEND="${CDEPEND}
+ sys-devel/gettext
+ x11-libs/libX11
+ x11-proto/xproto
+"
+RDEPEND="${CDEPEND}
+ !kde-misc/wacomtablet:4
+"