summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-07-02 17:30:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-07-02 21:50:51 +0200
commit47c510f6858c9c0c45992e5063f38850c2f8643f (patch)
tree3a6deed4c1306e2cfc58ee0d17995e9088705dd4 /kde-misc/zanshin/zanshin-0.4.1_p20170701.ebuild
parentapp-crypt/kencfs: Add kde-frameworks/kwallet as alt. RDEPEND (diff)
downloadgentoo-47c510f6858c9c0c45992e5063f38850c2f8643f.tar.gz
gentoo-47c510f6858c9c0c45992e5063f38850c2f8643f.tar.bz2
gentoo-47c510f6858c9c0c45992e5063f38850c2f8643f.zip
kde-misc/zanshin: Add 0.4.1_p20170701 snapshot
This should be much improved over 0.4.1 - however: To fix insta-crash at startup, the following commits are reverted: b0a2c3c2b9e6c2122d84b869bdf810acfcbcdd8d 108a6e32fb799ffb2c98d0be898a255d3d19d001 99b5b22c89e77d642cae3ca4104b157d3e4e295b a2826dab644d778ada9a13bddd5752c6c89032bc ...with the bad commit being one of: a5bf42ec164d5f150eed09da151389e57b05439d d782d8330fb97172486a495212c99d87edc30b60 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'kde-misc/zanshin/zanshin-0.4.1_p20170701.ebuild')
-rw-r--r--kde-misc/zanshin/zanshin-0.4.1_p20170701.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/kde-misc/zanshin/zanshin-0.4.1_p20170701.ebuild b/kde-misc/zanshin/zanshin-0.4.1_p20170701.ebuild
new file mode 100644
index 000000000000..75d5107bcfc3
--- /dev/null
+++ b/kde-misc/zanshin/zanshin-0.4.1_p20170701.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Getting things done application by KDE"
+HOMEPAGE="https://zanshin.kde.org/"
+SRC_URI="https://dev.gentoo.org/~asturm/distfiles/${P}.tar.xz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# FIXME: bundles libkdepim
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep krunner)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep akonadi-search)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kldap)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep kontactinterface)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ test? ( $(add_kdeapps_dep akonadi 'tools') )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-misc/zanshin:4
+ $(add_kdeapps_dep kdepim-runtime)
+"