summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-08-05 17:44:12 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-08-05 17:44:37 +1000
commitecf7e21b62d9b02a09a792b19d2a8e7676b3f9c3 (patch)
tree04b22f68710d0d77b1d5ccf02c32744bd70c3714 /kde-misc
parentsys-power/acpilight: add init script (diff)
downloadgentoo-ecf7e21b62d9b02a09a792b19d2a8e7676b3f9c3.tar.gz
gentoo-ecf7e21b62d9b02a09a792b19d2a8e7676b3f9c3.tar.bz2
gentoo-ecf7e21b62d9b02a09a792b19d2a8e7676b3f9c3.zip
kde-misc/kanyremote: version bump 6.4
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kanyremote/Manifest1
-rw-r--r--kde-misc/kanyremote/kanyremote-6.4.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/kde-misc/kanyremote/Manifest b/kde-misc/kanyremote/Manifest
index 31c4b613450f..668b58082668 100644
--- a/kde-misc/kanyremote/Manifest
+++ b/kde-misc/kanyremote/Manifest
@@ -1 +1,2 @@
DIST kanyremote-6.3.5.tar.gz 311639 SHA256 3fe3d186b503f43c30b2a8302a79810ee30d1ccf7839ceafcdda651915b4bbfe SHA512 2b40584097b8aedeaf1bbe66c1e4aab0a440111007e735f4573e7fc968ac9a7331e19e4ba288986e3428e7f3aed58d96ff1470101f0ba9098225c0053c706c5c WHIRLPOOL ef40e3e3239c77609d98fa86283f29be751cc2b4590c0ec76412839e3f21df7252cf63b95557ac5f4a61c6610e20029c432865812ccbe02184cf447373b0f214
+DIST kanyremote-6.4.tar.gz 316922 SHA256 f87a139f0a266ea2a54e153bf9f6f32ed1b425e37edf112dcd6b5f51649ae707 SHA512 a6a45bf1f086055e290238b899b5e9cd1ba47aa5b500a9036ea09750ada1fa4ded3105f6843188f0e8f1687ff4e6cf8f712e300dd303b0e5af3c2d67c103060d WHIRLPOOL 9729bc4ab6a292a85d99c937f623b4e0c2f737208458e67006ef67f7fac72dbe61e522c5c1c337b7c645b6c0bd9be624d2b1fe3a0ef9179bc266a4a468c97e79
diff --git a/kde-misc/kanyremote/kanyremote-6.4.ebuild b/kde-misc/kanyremote/kanyremote-6.4.ebuild
new file mode 100644
index 000000000000..c7caf16967e4
--- /dev/null
+++ b/kde-misc/kanyremote/kanyremote-6.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-r1
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-mobilephone/anyremote-6.5[bluetooth?]
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_prepare() {
+ # using gettextize no-interactive example from dev-util/bless package
+ cp $(type -p gettextize) "${T}"/ || die
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die
+ "${T}"/gettextize -f --no-changelog > /dev/null || die
+
+ # remove deprecated entry
+ sed -e "/Encoding=UTF-8/d" \
+ -i kanyremote.desktop || die "fixing .desktop file failed"
+
+ # fix documentation directory wrt bug #316087
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am || die
+ eautoreconf
+
+ # disable bluetooth check to avoid errors
+ if ! use bluetooth ; then
+ sed -e "s/usepybluez = True/usepybluez = False/" -i kanyremote || die
+ fi
+
+ default
+}
+
+src_install() {
+ default
+
+ python_replicate_script "${D}"/usr/bin/kanyremote
+}