summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-07 20:29:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-08 19:03:38 +0200
commitb3b5564327f160ed033b7c2d7781f0bb99f9dc85 (patch)
treebf8082f2f50b947e1305e878144414a8939194e3 /kde-plasma/drkonqi
parentnet-misc/vde: No more ltprune (diff)
downloadgentoo-b3b5564327f160ed033b7c2d7781f0bb99f9dc85.tar.gz
gentoo-b3b5564327f160ed033b7c2d7781f0bb99f9dc85.tar.bz2
gentoo-b3b5564327f160ed033b7c2d7781f0bb99f9dc85.zip
kde-plasma: Add KDE Plasma 5.15.5
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/drkonqi')
-rw-r--r--kde-plasma/drkonqi/Manifest1
-rw-r--r--kde-plasma/drkonqi/drkonqi-5.15.5.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/kde-plasma/drkonqi/Manifest b/kde-plasma/drkonqi/Manifest
index 7101cec64308..a0c40bfb74c3 100644
--- a/kde-plasma/drkonqi/Manifest
+++ b/kde-plasma/drkonqi/Manifest
@@ -1,2 +1,3 @@
DIST drkonqi-5.14.5.tar.xz 737580 BLAKE2B 1bb0ee7a70df8740feb6838bae7679c4acff4bf976e85a733da102db9716efcee5fd4f314f3877607ce600123b6452694a8fa528ea87a41f49d76b3bdb46f975 SHA512 8985ab8fae82e16fce6d604fcf6e4a393e1a147061f09eaaca6cd048fe9cba47cc9959013fc912b3829a9aaf3c471941597c5d1d3630f243fa1871e387757b36
DIST drkonqi-5.15.4.tar.xz 738768 BLAKE2B a76d500ba12ce01c83758441d968fe79fe507ca83ab2787941d1105ada88e9f599858565abe730b96f9a2795bc57b14bf18614b1d3e3c85de5c340cdc927b185 SHA512 49e71e883bcf805444f66beb579cdbd371d3cb9780d485b89ae2e75e1094b89d5182ac9351fa739375c519dc28e4a66f22af081c5e5336e01ab61a628aa7b692
+DIST drkonqi-5.15.5.tar.xz 738752 BLAKE2B e0a48064a1881079f44c727a1bc08b9e8906b2c3e83a3def8b5fd406b6aa4d2982ebb885f3038692568293da2d933d521735724b34b40fbbcc96b139c1595740 SHA512 812206194f095a4862023a085ac2975c107e2774010598a6bf1b9b88b8dfa1e78819ac4012854d607a61bcba6dc954554ac178ccb3fd304ed27adddefa1fe8c9
diff --git a/kde-plasma/drkonqi/drkonqi-5.15.5.ebuild b/kde-plasma/drkonqi/drkonqi-5.15.5.ebuild
new file mode 100644
index 000000000000..8dbc6989fc44
--- /dev/null
+++ b/kde-plasma/drkonqi/drkonqi-5.15.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Plasma crash handler, gives the user feedback if a program crashed"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="X"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlrpcclient)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ X? ( $(add_qt_dep qtx11extras) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep qtconcurrent)
+"
+RDEPEND="${COMMON_DEPEND}
+ !<kde-plasma/plasma-workspace-5.10.95:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X Qt5X11Extras)
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ if ! has_version "sys-devel/gdb"; then
+ elog "For more usability consider installing the following package:"
+ elog " sys-devel/gdb - Easier debugging support"
+ fi
+}