summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-02 20:21:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-02 23:05:24 +0200
commit55391d594cbb90254c591743415442484c3b0d02 (patch)
tree0495277eae519b0471a036e40a57ebd77d661530 /kde-plasma/kde-gtk-config
parentdev-python/pillow: bump to 6.0.0 (diff)
downloadgentoo-55391d594cbb90254c591743415442484c3b0d02.tar.gz
gentoo-55391d594cbb90254c591743415442484c3b0d02.tar.bz2
gentoo-55391d594cbb90254c591743415442484c3b0d02.zip
kde-plasma: Add KDE Plasma 5.15.4
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kde-gtk-config')
-rw-r--r--kde-plasma/kde-gtk-config/Manifest1
-rw-r--r--kde-plasma/kde-gtk-config/kde-gtk-config-5.15.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/kde-gtk-config/Manifest b/kde-plasma/kde-gtk-config/Manifest
index 5b1ae49fdb12..d6b4f0cc2e88 100644
--- a/kde-plasma/kde-gtk-config/Manifest
+++ b/kde-plasma/kde-gtk-config/Manifest
@@ -1,2 +1,3 @@
DIST kde-gtk-config-5.14.5.tar.xz 157032 BLAKE2B b13e44fbe1ea048e58b98f1396528372f74545effa145b65a71709f1e7732c0ed48111e52eaafc544d180678e411df20786a0f9cfee1557c1df873b4630e380f SHA512 3bb350307cabf44a27dcc3be95c8d2c15049be80f3c3fb127ddaaf9880acb850f10126347fba07868bfa9424d5e1c92b580687aa356be2869ff36684a15d8563
DIST kde-gtk-config-5.15.3.tar.xz 156808 BLAKE2B 0bbfb2254cfec5219b63e18ab6286379e5e1d7180a79a91ff163dcf30b35d5d51d4731bb60317cbb76a086414050c2f245fb36927ae5b53f0486906460329472 SHA512 0bf7df596564fffb502f4b7bfa5fea570c63e0e3e0f6a7e0483f327a7f9be10fbc7215a05387596bbd98ac946e5eb05f709b46a20c7c2e9c01ea2588388c52bc
+DIST kde-gtk-config-5.15.4.tar.xz 156896 BLAKE2B b841c2af6ea23195aef331822ebf349f0dbc988b4ad35d2923ccf8ed4488eab434045178bf6d0ac19d9eb774530dd4416615939bdc15f71d0a9a78cb57d13fcf SHA512 61bed4569a3b744b503f3eaa99bd02a8c7b178461d84aea253d39a7ede84107b75f58d222fd93d7b3fa31faace27c331fc24ac5f3d252c9fd02b3e83180273c2
diff --git a/kde-plasma/kde-gtk-config/kde-gtk-config-5.15.4.ebuild b/kde-plasma/kde-gtk-config/kde-gtk-config-5.15.4.ebuild
new file mode 100644
index 000000000000..03f067d76fe8
--- /dev/null
+++ b/kde-plasma/kde-gtk-config/kde-gtk-config-5.15.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Plasma systemsettings kcm to set GTK application look&feel"
+HOMEPAGE="https://cgit.kde.org/kde-gtk-config.git"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ dev-libs/glib:2
+ gnome-base/gsettings-desktop-schemas
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libXcursor
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDATA_INSTALL_DIR="${EPREFIX}/usr/share"
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "If you notice missing icons in your GTK applications, you may have to install"
+ elog "the corresponding themes for GTK. A good guess would be x11-themes/oxygen-gtk"
+ elog "for example."
+}