summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-15 16:04:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-23 15:59:12 +0100
commitec0f01d6f203167651da922e1277807af2c5abac (patch)
treec41f259ed2e397df80da250a850b767ec3e36876 /kde-plasma/kdeplasma-addons
parentkde-plasma/kdeplasma-addons: mediaframe: fix path URLs (diff)
downloadgentoo-ec0f01d6f203167651da922e1277807af2c5abac.tar.gz
gentoo-ec0f01d6f203167651da922e1277807af2c5abac.tar.bz2
gentoo-ec0f01d6f203167651da922e1277807af2c5abac.zip
kde-plasma/kdeplasma-addons: weather-applet: fix cursor
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kdeplasma-addons')
-rw-r--r--kde-plasma/kdeplasma-addons/files/kdeplasma-addons-5.23.3-weather-fix-cursor.patch35
-rw-r--r--kde-plasma/kdeplasma-addons/kdeplasma-addons-5.23.3-r1.ebuild1
2 files changed, 36 insertions, 0 deletions
diff --git a/kde-plasma/kdeplasma-addons/files/kdeplasma-addons-5.23.3-weather-fix-cursor.patch b/kde-plasma/kdeplasma-addons/files/kdeplasma-addons-5.23.3-weather-fix-cursor.patch
new file mode 100644
index 000000000000..d5b5ea84f609
--- /dev/null
+++ b/kde-plasma/kdeplasma-addons/files/kdeplasma-addons-5.23.3-weather-fix-cursor.patch
@@ -0,0 +1,35 @@
+From ea18868f6b49577b1349438d6e058199705a25b0 Mon Sep 17 00:00:00 2001
+From: Bharadwaj Raju <bharadwaj.raju777@protonmail.com>
+Date: Fri, 12 Nov 2021 15:55:50 +0000
+Subject: [PATCH] applets/weather: Make cursor a pointing hand when hovering
+ over source link
+
+Currently it's a normal pointer, which doesn't indicate that it's a clickable link.
+
+
+(cherry picked from commit 508fde69075026db28e7078a7e105acf1cc9c102)
+---
+ applets/weather/package/contents/ui/FullRepresentation.qml | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/applets/weather/package/contents/ui/FullRepresentation.qml b/applets/weather/package/contents/ui/FullRepresentation.qml
+index dc1583032..4a6d4bdff 100644
+--- a/applets/weather/package/contents/ui/FullRepresentation.qml
++++ b/applets/weather/package/contents/ui/FullRepresentation.qml
+@@ -40,6 +40,13 @@ ColumnLayout {
+
+ Layout.alignment: Qt.AlignVCenter | Qt.AlignRight
+
++ MouseArea {
++ anchors.fill: parent
++ hoverEnabled: true
++ acceptedButtons: Qt.NoButton
++ cursorShape: !!parent.creditUrl ? Qt.PointingHandCursor : Qt.ArrowCursor
++ }
++
+ wrapMode: Text.WordWrap
+ horizontalAlignment: Text.AlignRight
+ font {
+--
+GitLab
+
diff --git a/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.23.3-r1.ebuild b/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.23.3-r1.ebuild
index 73d939f3bafb..cbcb1e038b78 100644
--- a/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.23.3-r1.ebuild
+++ b/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.23.3-r1.ebuild
@@ -56,6 +56,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}"/${P}-mediaframe-fix-path-URLs.patch
+ "${FILESDIR}"/${P}-weather-fix-cursor.patch
)
src_configure() {