summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-23 12:16:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-23 18:46:25 +0200
commit04b7a5abc61721150cbdaefb391c4365903d11a1 (patch)
tree17167a551e6bc11df15961a74f7e0e1dbbb04cf6 /kde-plasma/kinfocenter
parentapp-crypt/argon2: Use optimized code on x86 only (diff)
downloadgentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.tar.gz
gentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.tar.bz2
gentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.zip
kde-plasma: KDE Plasma 5.17.1 version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.17.1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index cc628b66b6a4..2e8a77557d2f 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,2 +1,3 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.16.5.tar.xz 1321040 BLAKE2B b8c1e699d23175bc1048233aa589e91c31625f8a93da2b3ade5f71bf410723c853f2b4f0654a78be1f2c7a2350e66a8f932c4c0c7db9bbc2c22ac3ef9ff5b2a6 SHA512 1b98515beac87ff5394c06dd6029a2688db27a900f4c85fd4884d332a20120d553c25b98ae5ccfd7da2e6cbaa866edb84809f49c1c19922f25241acdc9e56832
+DIST kinfocenter-5.17.1.tar.xz 1343168 BLAKE2B 55c0c4ea4112a04416809cd0f6902aab17be57866d38648c2ce4c5648395c9b20da68036c9cc3b85af8da1212295c57d1ffc89b0dea2596194e438ac370bce85 SHA512 798a834265d7347a6221467f1e465fb645242a83f43b19bb44829b423f92ae81b12910e68a8a62434c9ff53f7417d33ef9c9dc39f55ea95de70836f27f22ad55
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.17.1.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.17.1.ebuild
new file mode 100644
index 000000000000..7bfec63201e8
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.17.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MIN_VERSION=3.14.3
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[gles2?,X(+)]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ $(add_qt_dep qtquickcontrols2)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ if has_version "dev-qt/qtgui[gles2]"; then
+ mycmakeargs+=( $(cmake-utils_use_find_package gles2 OpenGLES) )
+ else
+ mycmakeargs+=( $(cmake-utils_use_find_package opengl OpenGL) )
+ fi
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ has_version "net-fs/nfs-utils" || \
+ elog "Installing net-fs/nfs-utils will enable the NFS information module."
+
+ has_version "net-fs/samba" || \
+ elog "Installing net-fs/samba will enable the Samba status information module."
+ fi
+}