summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-03 15:30:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-03 18:39:51 +0200
commit0be4355642c0cdc8d1c79a1d5c297a8af6f87cde (patch)
tree65ba6d089b154a30a28b2d60ba3d324776d0b418 /kde-plasma/kinfocenter
parentprofiles/arch/sparc: enable ieee1275 support for grub (diff)
downloadgentoo-0be4355642c0cdc8d1c79a1d5c297a8af6f87cde.tar.gz
gentoo-0be4355642c0cdc8d1c79a1d5c297a8af6f87cde.tar.bz2
gentoo-0be4355642c0cdc8d1c79a1d5c297a8af6f87cde.zip
kde-plasma: Add KDE Plasma 5.16.5
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.16.5.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 0f520c4ba842..7380aff3d424 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.15.5.tar.xz 1321684 BLAKE2B 51a3b49a5b724d187f58513c87f0618b1ee71d00e4ed51019017ae427602b7135d6bd9419714c431e3440f8a27152c4a72951d929b727f200c5cf1d72fc3ac84 SHA512 d75561edc65701097e4c9249f1cb7208e14ee1e99acbd6521606c99ac8e4ebe9ab42a804d8ef7bcde138d3189e3dbd9aaad088563ae6364418e6119639ac3974
DIST kinfocenter-5.16.4.tar.xz 1322888 BLAKE2B 4b4b605afac333c5ba8aa0dd08aeb025f0effe4a8e7d47ceb793a5d7a9903e9181441abcacd15066903ad9587a5140a3767b9ab3b717e03e089dad4b371281c3 SHA512 407686f5bba77c5907e550e0c83fb6dcdb2095c87ba9654f1483eb784847a67f58c26c9ceaed1844353ab495c01326f6bf840eb9c20f11a20dc48bed99e1c732
+DIST kinfocenter-5.16.5.tar.xz 1320652 BLAKE2B a179df76d33a759f42db9cddfb58369be2cbb494ba3773019e4ff07272a758bf66f7f61c7384cc6844f738a31ee8c746294885a25181d37ca2af9ccdae580413 SHA512 66530fe8d25141fc5e3d2d85bfddc64febc2a92eb1e5011e0a29e36206d09fab07aa2bffc16419e225d69506afe2806d6183c0dd7deda562f7f572b2105a48b3
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.16.5.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.16.5.ebuild
new file mode 100644
index 000000000000..7bfec63201e8
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.16.5.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MIN_VERSION=3.14.3
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[gles2?,X(+)]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ $(add_qt_dep qtquickcontrols2)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ if has_version "dev-qt/qtgui[gles2]"; then
+ mycmakeargs+=( $(cmake-utils_use_find_package gles2 OpenGLES) )
+ else
+ mycmakeargs+=( $(cmake-utils_use_find_package opengl OpenGL) )
+ fi
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ has_version "net-fs/nfs-utils" || \
+ elog "Installing net-fs/nfs-utils will enable the NFS information module."
+
+ has_version "net-fs/samba" || \
+ elog "Installing net-fs/samba will enable the Samba status information module."
+ fi
+}