summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-07 19:28:35 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-07 19:30:35 +0100
commit1a442e7816b99589e145656e21d3a41c679b917a (patch)
treec3163b27808cd7a056c3ab7653f8f11fb4df3544 /kde-plasma/kscreenlocker
parentx11-wm/musca: Fix toolong DESCRIPTION (diff)
downloadgentoo-1a442e7816b99589e145656e21d3a41c679b917a.tar.gz
gentoo-1a442e7816b99589e145656e21d3a41c679b917a.tar.bz2
gentoo-1a442e7816b99589e145656e21d3a41c679b917a.zip
kde-plasma: Version bump KDE Plasma 5.9.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-plasma/kscreenlocker')
-rw-r--r--kde-plasma/kscreenlocker/Manifest1
-rw-r--r--kde-plasma/kscreenlocker/kscreenlocker-5.9.1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/kde-plasma/kscreenlocker/Manifest b/kde-plasma/kscreenlocker/Manifest
index 87f5845fec9d..f4c40c4aa3ef 100644
--- a/kde-plasma/kscreenlocker/Manifest
+++ b/kde-plasma/kscreenlocker/Manifest
@@ -1,2 +1,3 @@
DIST kscreenlocker-5.8.5.tar.xz 108100 SHA256 72d64837393dd5c237d2985574b85a0f6507152ec3d5256751354c08d9d86285 SHA512 63d25d3e8c1477a7d1a52d49c32265fe344d7c7c1d5f9cb642d6e9ab524fc0a24c1de30e7134d3d92d3bf47a1d93d2a4713742aacb1405d35f8d5a04e66e0685 WHIRLPOOL 131cb22cf4830abc21bb1a1116ac11c6817fdd1e99441938e938a5bd44ba470b0f63bea073122bc093d016c3c72d733ca678688b1a311cc33d8c9b3127e65960
DIST kscreenlocker-5.9.0.tar.xz 107876 SHA256 8f5386672ed7382a799edb27793f19d86a909215fbe6d22d7f2839e70fe6a75f SHA512 e21508ec26622850705e7a532310bb13e4b9bec025f24d0eabb005e9d6ea7f98817b48530bd7840589b4be7c7ef74c8ec537ba3661a1b63630bb9164f27db021 WHIRLPOOL 79e52dbc04c5b9ff9a4b167bb7df4e89e4c6516599764d147b574e51bef1a3a6dfaed839e67c88fcb810be5989f86cbabe8fe9e72b714a9f79a326a46d238209
+DIST kscreenlocker-5.9.1.tar.xz 107884 SHA256 fffe0506763bcd138ba4f7750d23a16e947619cfb4ae370825f94e28a0e24166 SHA512 905692e2a761a4925eeb00e66d0343c60408752d0b12721587260f593f809f0c32f743332535168db677df3483c40a3dc905666f77e70cd1fe6338d4621ef89e WHIRLPOOL fa5b5c992d102065495f9ebf4a5ebed88673dbc70e02e612ce6d3735eef98e30d0cbdd7a350ef23ef70d7ddce663556bc153d0d5c34e08ccfa88ba67d22c2f06
diff --git a/kde-plasma/kscreenlocker/kscreenlocker-5.9.1.ebuild b/kde-plasma/kscreenlocker/kscreenlocker-5.9.1.ebuild
new file mode 100644
index 000000000000..9c1a67e6f762
--- /dev/null
+++ b/kde-plasma/kscreenlocker/kscreenlocker-5.9.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5 pam
+
+DESCRIPTION="Library and components for secure lock screen architecture"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="pam"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ dev-libs/wayland
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ pam? ( virtual/pam )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !<kde-plasma/kcheckpass-4.11.22-r1:4
+ !kde-plasma/kdebase-pam:0
+"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ kde5_src_prepare
+
+ use test || sed -i \
+ -e "/add_subdirectory(autotests)/ s/^/#/" greeter/CMakeLists.txt || die
+}
+
+src_test() {
+ # requires running environment
+ local myctestargs=(
+ -E x11LockerTest
+ )
+ kde5_src_test
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package pam PAM)
+ )
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ newpamd "${FILESDIR}/kde.pam" kde
+ newpamd "${FILESDIR}/kde-np.pam" kde-np
+
+ if ! use pam; then
+ chown root "${ED}"usr/$(get_libdir)/libexec/kcheckpass || die
+ chmod +s "${ED}"usr/$(get_libdir)/libexec/kcheckpass || die
+ fi
+}