summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-03-29 22:15:32 +0200
committerJohannes Huber <johu@gentoo.org>2016-03-29 22:19:20 +0200
commit30cab995774241d564efbb4df148c3a636172b9a (patch)
treefcfa560b8a2507a749b322260a7a8e5aa33c0c13 /kde-plasma/kscreenlocker
parentwww-client/google-chrome-unstable: automated update (diff)
downloadgentoo-30cab995774241d564efbb4df148c3a636172b9a.tar.gz
gentoo-30cab995774241d564efbb4df148c3a636172b9a.tar.bz2
gentoo-30cab995774241d564efbb4df148c3a636172b9a.zip
kde-plasma: Version bump KDE Plasma 5.6.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-plasma/kscreenlocker')
-rw-r--r--kde-plasma/kscreenlocker/Manifest1
-rw-r--r--kde-plasma/kscreenlocker/kscreenlocker-5.6.1.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/kde-plasma/kscreenlocker/Manifest b/kde-plasma/kscreenlocker/Manifest
index 06f446de6586..744f51bacb3e 100644
--- a/kde-plasma/kscreenlocker/Manifest
+++ b/kde-plasma/kscreenlocker/Manifest
@@ -1 +1,2 @@
DIST kscreenlocker-5.5.5.tar.xz 98400 SHA256 7cad8630831094dc1cde7d828df750191eb032c908a6bccc6d5d83b15a235803 SHA512 290341230f96db32d9c0b767f46994c91c3a5809799830c2b377a79e3163c53c484114f63a85aa0eede1763e06611e07c677cfa0678350921f14b764da798135 WHIRLPOOL accdc244e23e6f0f749ef87bee122b5f03506b875731c8a59027f2a90eb64331e272f92e89d375baa1d677611b244eb882da944088b5269eacbc854205125794
+DIST kscreenlocker-5.6.1.tar.xz 103896 SHA256 8071a4bdef749cd392d0080b09827e5613e92d36283880ea6c1224211a0a01ef SHA512 27d657d4ecc7c009146a9a462f74163922a4b30222a52d3f2e7fae28ce44de7ff9a1c1b762c38c4a75550ac765eec579f8a9d6bd63c3504c5e2ed2eebd32c656 WHIRLPOOL c7812b85e9094993fd02e9553b942461f90ab27f11c7cc3c4e0ca6bacd8d3804730faf655602b85b44bbd4c5de6437bea0eeb11964e4338cd41ec07797ae4789
diff --git a/kde-plasma/kscreenlocker/kscreenlocker-5.6.1.ebuild b/kde-plasma/kscreenlocker/kscreenlocker-5.6.1.ebuild
new file mode 100644
index 000000000000..0bc30781612c
--- /dev/null
+++ b/kde-plasma/kscreenlocker/kscreenlocker-5.6.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5 pam
+
+DESCRIPTION="Library and components for secure lock screen architecture"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="pam"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_plasma_dep kwayland)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ dev-libs/wayland
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ pam? ( virtual/pam )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !<kde-base/kcheckpass-4.11.22-r1:4
+ !kde-base/kdebase-pam:0
+ !<kde-plasma/plasma-workspace-5.4.50
+"
+
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-5.4.90-no-SUID-no-GUID.patch" )
+
+src_prepare() {
+ kde5_src_prepare
+
+ use test || sed -i \
+ -e "/add_subdirectory(autotests)/ s/^/#/" greeter/CMakeLists.txt || die
+}
+
+src_test() {
+ # requires running environment
+ local myctestargs=(
+ -E x11LockerTest
+ )
+ kde5_src_test
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package pam PAM)
+ )
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ newpamd "${FILESDIR}/kde.pam" kde
+ newpamd "${FILESDIR}/kde-np.pam" kde-np
+
+ if ! use pam; then
+ chown root "${ED}"usr/$(get_libdir)/libexec/kcheckpass || die
+ chmod +s "${ED}"usr/$(get_libdir)/libexec/kcheckpass || die
+ fi
+}