summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-01 20:22:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-02 00:57:20 +0200
commit7be87d03197beed0aed5eb18d03f2665f7617bca (patch)
tree7f82e93a52f4a4526e557e5e8b2d7972fb423856 /kde-plasma/kscreenlocker
parentkde-plasma/kscreenlocker: Disable seccomp sandboxing in 5.19 too (diff)
downloadgentoo-7be87d03197beed0aed5eb18d03f2665f7617bca.tar.gz
gentoo-7be87d03197beed0aed5eb18d03f2665f7617bca.tar.bz2
gentoo-7be87d03197beed0aed5eb18d03f2665f7617bca.zip
kde-plasma/kscreenlocker: Make ConsoleKit switch always accessible
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kscreenlocker')
-rw-r--r--kde-plasma/kscreenlocker/files/kscreenlocker-5.19.5-ck-unlock.patch32
-rw-r--r--kde-plasma/kscreenlocker/kscreenlocker-5.19.4-r1.ebuild4
2 files changed, 35 insertions, 1 deletions
diff --git a/kde-plasma/kscreenlocker/files/kscreenlocker-5.19.5-ck-unlock.patch b/kde-plasma/kscreenlocker/files/kscreenlocker-5.19.5-ck-unlock.patch
new file mode 100644
index 000000000000..bb15eba72b86
--- /dev/null
+++ b/kde-plasma/kscreenlocker/files/kscreenlocker-5.19.5-ck-unlock.patch
@@ -0,0 +1,32 @@
+From 1bac5f6e50bc3255ab0e4c9183e7456f53acfdd5 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 1 Aug 2020 20:05:17 +0200
+Subject: [PATCH] Provide ConsoleKit switch irrespective of HAVE_LOGINCTL
+
+---
+ CMakeLists.txt | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 60d3ee1..aaebc82 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -92,7 +92,6 @@ set_package_properties(loginctl PROPERTIES
+ )
+ set(HAVE_LOGINCTL ${loginctl_FOUND})
+
+-if ( NOT HAVE_LOGINCTL )
+ find_package(ConsoleKit)
+ set_package_properties(ConsoleKit PROPERTIES
+ URL "https://github.com/ConsoleKit2/ConsoleKit2"
+@@ -100,7 +99,6 @@ if ( NOT HAVE_LOGINCTL )
+ TYPE RECOMMENDED
+ )
+ set(HAVE_CONSOLEKIT ${ConsoleKit_FOUND})
+-endif ()
+
+ if (HAVE_LOGINCTL OR HAVE_CONSOLEKIT)
+ set(HAVE_UNLOCK_CAPABILITY TRUE)
+--
+2.28.0
+
diff --git a/kde-plasma/kscreenlocker/kscreenlocker-5.19.4-r1.ebuild b/kde-plasma/kscreenlocker/kscreenlocker-5.19.4-r1.ebuild
index 06317c83154a..8848223ae78c 100644
--- a/kde-plasma/kscreenlocker/kscreenlocker-5.19.4-r1.ebuild
+++ b/kde-plasma/kscreenlocker/kscreenlocker-5.19.4-r1.ebuild
@@ -57,6 +57,8 @@ PDEPEND="
RESTRICT+=" test"
+PATCHES=( "${FILESDIR}/${PN}-5.19.5-ck-unlock.patch" )
+
src_prepare() {
ecm_src_prepare
@@ -77,7 +79,7 @@ src_test() {
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Seccomp=ON
- $(cmake_use_find_package consolekit loginctl)
+ $(cmake_use_find_package consolekit ConsoleKit)
-DPAM_REQUIRED=$(usex pam)
$(cmake_use_find_package pam PAM)
)