summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-09 12:40:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-09 13:44:39 +0200
commitd26f2b068bcf024c6ad30fc227cc02eccbb797ae (patch)
tree1ac2b23f2ebc21dcad4a89018194a2226f0698dc /kde-plasma/ksshaskpass
parentdev-libs/libburn: Remove old libburn-1.5.0. (diff)
downloadgentoo-d26f2b068bcf024c6ad30fc227cc02eccbb797ae.tar.gz
gentoo-d26f2b068bcf024c6ad30fc227cc02eccbb797ae.tar.bz2
gentoo-d26f2b068bcf024c6ad30fc227cc02eccbb797ae.zip
kde-plasma: Add KDE Plasma 5.19.0
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.19.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index f2cc81821e65..7ea259c8e1d2 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1 +1,2 @@
DIST ksshaskpass-5.18.5.tar.xz 22148 BLAKE2B 31521b28a840bfbb14cdef2484dde8908a0ffbeda5d54663243bd93a070d77d72019b5436f0a4f838e7c8b9f60992b06636e181b6ced51d17a13ba4f7c3918b6 SHA512 8cf75491c04537cdbab11613dc0f9317631c282e4f371664164dc0936d08f744a39777b696b772e05b06ef1257d42f7ae29abfbbd022e661073fdf880fe63fcf
+DIST ksshaskpass-5.19.0.tar.xz 23496 BLAKE2B 845ba5bc26ae5a34e2834fb52dd12b5f26d89985ac855689029b80a5133485ad41e338af8904ddb1809bf3cdf1d83a15fe40f257c7ef058185ad7eeeb6a13922 SHA512 ce9649e9bb4c50c44b47e169ea63cefc0cbdc27356d30904aa277d1a4c05ac17f8ce90dddf73d999b7f2a599c94043f0384735da4e78b338ca60dd0895730524
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.19.0.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.19.0.ebuild
new file mode 100644
index 000000000000..384435c63bd4
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.19.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.70.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.14.1
+inherit ecm kde.org
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ ecm_pkg_setup
+
+ local srcfile=/etc/plasma/startup/05-ksshaskpass.sh
+ local newfile=/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh
+ if [[ -f "${EROOT}"${srcfile} ]]; then
+ local md5=$(md5sum "${EROOT}"${srcfile})
+ if [[ ${md5%% *} != 615ae8f5b0090ff7f51d0edee7885d55 ]]; then
+ elog "Existing modified "${EPREFIX}"${srcfile} detected."
+ elog "Copying to "${EPREFIX}"${newfile}..."
+ cp -v "${EROOT}"${srcfile} "${T}"/ || die
+ fi
+ fi
+}
+
+src_prepare() {
+ ecm_src_prepare
+ if [[ ! -f "${T}"/05-ksshaskpass.sh ]]; then
+ cp "${FILESDIR}"/05-ksshaskpass.sh "${T}"/ || die
+ fi
+}
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 script
+ if [[ -e "${EROOT}"/etc/plasma/startup/05-ksshaskpass.sh ]]; then
+ rm "${EROOT}"/etc/plasma/startup/05-ksshaskpass.sh || die
+ elog "Removed obsolete ${EPREFIX}/etc/plasma/startup/05-ksshaskpass.sh"
+ fi
+}