summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-18 16:25:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-18 18:11:40 +0200
commitdd8e6c848a97aea2c41c5c69bc0aa5585722e39c (patch)
tree9b0bb4507fb9ec18c0af393f5d98e0e15b7eeba2 /kde-plasma/ksshaskpass
parentnet-misc/cadaver: Add ${EPREFIX}. (diff)
downloadgentoo-dd8e6c848a97aea2c41c5c69bc0aa5585722e39c.tar.gz
gentoo-dd8e6c848a97aea2c41c5c69bc0aa5585722e39c.tar.bz2
gentoo-dd8e6c848a97aea2c41c5c69bc0aa5585722e39c.zip
kde-plasma: Add KDE Plasma 5.16.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.16.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index bdcb2cd13740..6b312bae4cd6 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.15.5.tar.xz 21304 BLAKE2B 8664f783d08d789aab81e40cc6d0a7248f0fe25bab20803579ce0c3869a412d2fc8fecf709b4bfe7d900dc7b9af59042d4e648d5b5730a8fb7108f4ac39ba362 SHA512 296581dafc7068a0e536fb3f10dbd56bd288bec5b93f96e5f7d7b03be6cf9f279dbdeccc8c53da21316fa18d758e92513d8f5441d9e80dfee452c26ef1dddcbc
DIST ksshaskpass-5.16.0.tar.xz 21364 BLAKE2B 514ca74ab5c52cde2f09dd8791c3c32612d8dfe5a0f3398ff29f6b3122266b894a72a06a2f4b280216786be8022b37236bb394b23f53cef4a45970875814353d SHA512 ebf64d4ce6dcc4036e77affd653201e6fd363257976b4979d84b18c3e60694abcd94dcca2d0a1db16bbe8ece0442bca9d81a1195ab0643f815db93625f3a9a19
+DIST ksshaskpass-5.16.1.tar.xz 21368 BLAKE2B ccb238b867851ca821414f6f0230118bc1f8589bf06ab8e65a74312fb8c1f9e93fefc9eb511b6d65bfe4efb628aa2562297023e13ae983b406000933135da421 SHA512 1046c5e598b9c170767441d4ecff1f4def0e2f87fac97ab96dfe0ecb93dea903afb573172952c7d1362c9bad7ca8441a13c6a2922558a92bb6c9b13e316ea426
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.16.1.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.16.1.ebuild
new file mode 100644
index 000000000000..55652bdcf792
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.16.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}