summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-12-16 01:14:15 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-12-16 02:31:23 +1100
commite3eeda55533ee0564c283466854c25eab97a1678 (patch)
tree1b471207f3edb955d2145cdadaae6566cae419fc /kde-plasma/ksshaskpass
parentdev-db/percona-server: Fix ebuild tests wrt bug 568328 (diff)
downloadgentoo-e3eeda55533ee0564c283466854c25eab97a1678.tar.gz
gentoo-e3eeda55533ee0564c283466854c25eab97a1678.tar.bz2
gentoo-e3eeda55533ee0564c283466854c25eab97a1678.zip
kde-plasma: version bump 5.5.1
Package-Manager: portage-2.2.26
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.5.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index f52f32b3d50e..56c03bd6bdf8 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.4.3.tar.xz 19476 SHA256 7eb6025e58e8cd57cab640ab42ff9670ae113317534001be94916610135127a3 SHA512 b8378263806014c225a3c7337c1fcf0a513cf508db718e6154304f49841e0d3744b61a58058093e021f4ace8b282842bb7d90ae5a9ad912af222cbaedaac0aad WHIRLPOOL ed0c6a399bc4338b1b17ea2c790f1f9490eb1f2de01aa3b1aa5dcb8a7c919f5b4895e0eea65c76b624d2071436f1a0c60cc1256d0a320a60b8dccd4ea1af1031
DIST ksshaskpass-5.5.0.tar.xz 20360 SHA256 10c2c4bbfdab8eb340e1a59f9378178b2c76493f512a7ff7dfceeafd3643a88a SHA512 0449d4719d3ce6d686bfd91b96987bda7f5b83ba4653a408002be2f6d7875743693150d8b4ed77c2e26781091795f248d26d9969a8b5b86d6c8e453386239473 WHIRLPOOL 438bcbec379aee04d52caf41fd6f9f8c39470c2c40a68bb9d32efad7628d336336239d61d8b106f3b68e77f2e16da3a3a28c73837a36541441f3731af686938c
+DIST ksshaskpass-5.5.1.tar.xz 20332 SHA256 1bd5b7b9e4ef58c4f1586af1818fea25cd772eba6f5d2285bcfea8cb4d814e75 SHA512 409493edf4b4f121993dbb30160b0a18dd2b8774a11334024ba5f6c930e046b95017accb3538654fc250d38513f63cedbed21cca7c61bdf80b6ee2e22a9632c8 WHIRLPOOL 0472fba59672db4785ea6a6af8bb403d5c62c3da383764bbf03cbad1972428aeb4ea892afbaffe936aa97d0d5551566b1325c46c658946499894c287a5a1d359
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.5.1.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.5.1.ebuild
new file mode 100644
index 000000000000..1dd193540c9e
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/ksshaskpass"
+KEYWORDS=" ~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ dev-qt/qtwidgets:5
+"
+RDEPEND="
+ ${DEPEND}
+ !net-misc/ksshaskpass
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/ksshaskpass.sh"
+ elog ""
+}