summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-02 20:21:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-02 23:05:24 +0200
commit55391d594cbb90254c591743415442484c3b0d02 (patch)
tree0495277eae519b0471a036e40a57ebd77d661530 /kde-plasma/ksysguard
parentdev-python/pillow: bump to 6.0.0 (diff)
downloadgentoo-55391d594cbb90254c591743415442484c3b0d02.tar.gz
gentoo-55391d594cbb90254c591743415442484c3b0d02.tar.bz2
gentoo-55391d594cbb90254c591743415442484c3b0d02.zip
kde-plasma: Add KDE Plasma 5.15.4
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest1
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.15.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index b555ca6ae0a2..f1591e1a0342 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1,2 +1,3 @@
DIST ksysguard-5.14.5.tar.xz 501624 BLAKE2B 1d2a19d268653768affce6c746340fc1ab3e5f77cca939e6ec58f9e4285d51bffb0026f65489db54d43799df95983288d6d59d38c52aec2f63f3d668b94757db SHA512 fb04538b500f3d3dd0a3f6fa1a0adf1d3a72e2647bb48eebff8fac2c00d5f3a1de18cf4ea35bb6daa210976514bfe3d8adf8a6785d279535b0e2b4b82f25ba67
DIST ksysguard-5.15.3.tar.xz 500592 BLAKE2B cc0e10178fafe615c2471bed66dadf1a30b81f4d27e3d8fab25a346acc9e318b7ed00cced9d93ecd30cb204deda87ff2408ffecd4d2fc67e2b7ecde362c921ac SHA512 32de12d33df32341d76a8631ff1dcf3b392df31bc14b543cdb5e6063f0e8ecd5f216912f5b40309b0db10c2b51ed12521344935d7f35cb2ebe8c8c9a91f7400c
+DIST ksysguard-5.15.4.tar.xz 500016 BLAKE2B ef9429bcfda7ff3d8369fc24d6e2dc93a59b8f17989016c7d983928c5201f4ab0e6ead1eb2109b3f005b161c30d80ea9c5f0d21887a3be685390f1732b933c46 SHA512 93d9404ceb8819cbe847a080a9a20835d8f68253e9772ea5f91fa9c2a8c1d20abe1427492c0788316efd6a4f973dc158d516ea6d16b4b9837fc963b4a85aead0
diff --git a/kde-plasma/ksysguard/ksysguard-5.15.4.ebuild b/kde-plasma/ksysguard/ksysguard-5.15.4.ebuild
new file mode 100644
index 000000000000..dc21acd63e69
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.15.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}