summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-08 13:40:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-08 14:32:55 +0100
commit5e0f583660d70d633152b9639af6b52e6f690090 (patch)
tree361e6c35245cbfb031ee399a9d3d441768480d8e /kde-plasma/ksysguard
parentdev-lang/ruby: Added sys-libs/readline to RDEPEND. (diff)
downloadgentoo-5e0f583660d70d633152b9639af6b52e6f690090.tar.gz
gentoo-5e0f583660d70d633152b9639af6b52e6f690090.tar.bz2
gentoo-5e0f583660d70d633152b9639af6b52e6f690090.zip
kde-plasma: Add KDE Plasma 5.14.5
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest1
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.14.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index 4c1a6aaca8d8..dec194dc82f8 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1,2 +1,3 @@
DIST ksysguard-5.14.3.tar.xz 501720 BLAKE2B b3b4ef98ba78c3c30fa76b6914ed93d5a002b1806fc59ad778b27082eb39acdafb68f815743f88cf4d43a4c10cc2de4070603ae5ee18d93a25e7299f0cd0839e SHA512 aa1d2007ffe0b4ad30e3e54a98cb56980d7666a36c879039952a2e589fe054ee773d3b495fbf3605777ed616e90f6f959ade3768e874f45f44223666b398de25
DIST ksysguard-5.14.4.tar.xz 501544 BLAKE2B c71f517cb923043519f3ce1fffaf0f583e7a10dcdc8ef1125b68771e0aabade329d8b67349b9228990e1c2ef0c7a85d6f42746e670bb2fd4bd21380e27b91a12 SHA512 af59db3d8efd50516e4800e21d6eb6d5236d214b5fb9831065947e803e54a603187d113b3b3582d35be16031d86bc2a374e1440baa943ea421af1d8455400870
+DIST ksysguard-5.14.5.tar.xz 501624 BLAKE2B 1d2a19d268653768affce6c746340fc1ab3e5f77cca939e6ec58f9e4285d51bffb0026f65489db54d43799df95983288d6d59d38c52aec2f63f3d668b94757db SHA512 fb04538b500f3d3dd0a3f6fa1a0adf1d3a72e2647bb48eebff8fac2c00d5f3a1de18cf4ea35bb6daa210976514bfe3d8adf8a6785d279535b0e2b4b82f25ba67
diff --git a/kde-plasma/ksysguard/ksysguard-5.14.5.ebuild b/kde-plasma/ksysguard/ksysguard-5.14.5.ebuild
new file mode 100644
index 000000000000..9e4106a07d7f
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.14.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors:= )
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/ksysguard:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}