summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-09 19:27:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-09 21:06:30 +0200
commit75f3bdb77de6cbe367d9f34ffc29c95e4183475c (patch)
tree46ab7edb5c7b440db31907f97bc2b86df5052685 /kde-plasma/ksysguard
parentapp-emulation/libvirt: update live ebuild (diff)
downloadgentoo-75f3bdb77de6cbe367d9f34ffc29c95e4183475c.tar.gz
gentoo-75f3bdb77de6cbe367d9f34ffc29c95e4183475c.tar.bz2
gentoo-75f3bdb77de6cbe367d9f34ffc29c95e4183475c.zip
kde-plasma: Add KDE Plasma 5.16.3
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest1
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.16.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index bea95892e2a8..9908c29de580 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1,2 +1,3 @@
DIST ksysguard-5.15.5.tar.xz 500116 BLAKE2B 1a22e419af79685e241265d392eed7502998df88168adc4292c8500a152a8d1142d56c4a34dee409b29745d8a07f889c241b3ab9ab8f09f3eec68d1ec5826c79 SHA512 ae74adac0a4b20d9ddcf9b172542a3c96de46adb66b2f6c1d4e5f97562572e365f777d1daffd82e677ca1be37e868425112f69bd6e85e51118dc557f66ab5b8e
DIST ksysguard-5.16.2.tar.xz 500496 BLAKE2B 95aa0af969428e1c3325a501d978c3cdda429486af6e31905b824fbccdfd7395762770785c236c2c516234b7ab41b3719099623606faeea45f4edd4670dcf867 SHA512 3addf9fd9c7b30ec1c54edc9afdeef055a530cedef870defe1ac9360d4ba2003c430c06b5fd1ad8a40fd13744c1935c31800e6e3653e10aad369d11e03886728
+DIST ksysguard-5.16.3.tar.xz 501376 BLAKE2B 210b05c62c50f78295a6e19a455bac6bf190f703ac9c5b515a0f251d250784ea853ebfc8481c0697d22b08a756f05f38a78fafab5f2b2f6d63e187d4260ccf13 SHA512 295566778727255b00aed2d686eaedc22cd51e7e7866ec5ca0ba9d6fbae73c66a6a49a8d7ed9e61b55d8402a11e6c80cc123fedde2b5f61d022256e1e745917b
diff --git a/kde-plasma/ksysguard/ksysguard-5.16.3.ebuild b/kde-plasma/ksysguard/ksysguard-5.16.3.ebuild
new file mode 100644
index 000000000000..dc21acd63e69
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.16.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}