summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-30 14:35:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-30 16:32:29 +0200
commit3a88c6f1b382ab5ebfe61539039a694c0e123991 (patch)
tree08f3cf35bc863ba6278e2950b9c5e72e83efe7be /kde-plasma/kwallet-pam
parentacct-group/kvm: make virtualization the primary maintainer (diff)
downloadgentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.tar.gz
gentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.tar.bz2
gentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.zip
kde-plasma: Add KDE Plasma 5.16.4
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.16.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index ab0a11842b2c..1d9a2cbf5439 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.15.5.tar.xz 19332 BLAKE2B b5d552500584888d6fd2662e7332623f51ec4a90885c983f492fbff8768b144a5d0bfff8e7466f68b833bbea436b9424b55f221402e1c9ddc8626be63910b521 SHA512 4a1a0b6f4d607a71b2dee3317acd0af1c76991a628be50d67c8231d756255577fe90e0f938050c8f6d6f295d5299deb8a88afbd7eac28050d3b905267bfd7636
DIST kwallet-pam-5.16.3.tar.xz 19568 BLAKE2B c44235c5c8dd50e556393fa8bc31e270e31376b1864b5cd239e386690f26bea008bbecfd8ca9a83dd7f155fefd7370e013bf1d2cbcafa1e293b69ad75969f699 SHA512 f5178e412c7802cf2b39139164fb2878e2765b51edd7bd26b2de156e7facb049cc1f299c7611d06abb308f7df9c79c4992abd6494cc2c60db0db7c2ef0c0fbc2
+DIST kwallet-pam-5.16.4.tar.xz 19644 BLAKE2B e40cbd3ec345b9fd3d43d2d1a53eb72d3c6dfd6413d787c5b4680566477a164a2f8bf0c2c82b0a6d8d71cc8bc6c5e06d171642cf1b60645c3a70482cd9bf9dc7 SHA512 5072afd940bc0fac823a6a050868c41bba27eb48a5a04b83e70a975c744dff64d23e1a1c2fcadcdd45712be94d0395ba13d6f8565abc9767d68eff6ede4fdcab
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.16.4.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.16.4.ebuild
new file mode 100644
index 000000000000..f3e1c598ec6c
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.16.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kwallet)
+ dev-libs/libgcrypt:0=
+ virtual/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}