summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-29 21:43:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-29 23:21:35 +0100
commit484c9dded4c2473cc9cf94f0ea2f4b87ae3ee5fd (patch)
tree38d93021acd0016cf8d9e739e232b856cdaace75 /kde-plasma/kwallet-pam
parentprofiles: arm64: Add kde-plasma/plasma-meta[thunderbolt] to p.use.mask (diff)
downloadgentoo-484c9dded4c2473cc9cf94f0ea2f4b87ae3ee5fd.tar.gz
gentoo-484c9dded4c2473cc9cf94f0ea2f4b87ae3ee5fd.tar.bz2
gentoo-484c9dded4c2473cc9cf94f0ea2f4b87ae3ee5fd.zip
kde-plasma: Add KDE Plasma 5.17.2
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.17.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index c4f986b48483..8d7da3af0fe7 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.16.5.tar.xz 19512 BLAKE2B dc053b8b02d44a3b94fe16d50b03bf91718392bdce60e69b956e5a84406012b567f4216b08b4d05c215cfa0e9e16c7537b60420a80bf501402a7cf302b853d9b SHA512 6a3c09b645a193bd5164525c6ca0c807a0adc141566db7436101784fef8def79e121c599a837dac32393f8e5ab2c33a9473a29013d07bd64e6a8eab32308d3d1
DIST kwallet-pam-5.17.1.tar.xz 19716 BLAKE2B 7b70aa2afab3f2db210cd3a95659feeb75dcf4e1af647adfb20585e74011443622d3031c959825104a596721d657da89cbdb85dc8fcf3b72151724f6f288d7a0 SHA512 63867da87e4a1003a6709af47460936e538341b0f7272570ec741869b9cfc9c1ebfaf765c74149375233ae30c8c8352f44410f5348a21b8777208e5bf51bbae1
+DIST kwallet-pam-5.17.2.tar.xz 19712 BLAKE2B 24da5b28399a9e7a98c5ea9077e019610075b7df3934651e1f3237fcd514ae76eab7f7a7a00080529d410b0eb9b2acb53481ad92668691b1099c66c5d17245b3 SHA512 5f3d8408488f6ae1e9b8f1a2e1975ccad3b8ca6bd9ff9a721f7ff83f50259d7a459a66bd48963702669c3751abe467917e0a7ebed5a05ed789a504c5ced29ffc
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.17.2.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.17.2.ebuild
new file mode 100644
index 000000000000..3b8009a01722
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.17.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kwallet)
+ dev-libs/libgcrypt:0=
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}