summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-04 20:43:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-04 21:06:09 +0200
commit19e5849dc0ee3139185562d1d16bb2dba680fb71 (patch)
treeb8d8f27de6ede8aaf8b472ce8cdba3a4574fefd9 /kde-plasma/kwayland-integration
parentkde-plasma/kwallet-pam: 5.27.4 version bump (diff)
downloadgentoo-19e5849dc0ee3139185562d1d16bb2dba680fb71.tar.gz
gentoo-19e5849dc0ee3139185562d1d16bb2dba680fb71.tar.bz2
gentoo-19e5849dc0ee3139185562d1d16bb2dba680fb71.zip
kde-plasma/kwayland-integration: 5.27.4 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.27.4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index 8168146dd6e2..c7e4407b32e2 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-integration-5.26.5.tar.xz 26972 BLAKE2B 108eeebc92768755fba22d7435829f514904a3f39c748a70f220c1ae4fa078d5def0921f6c96effc2c7cc1ae0580d8c251034e87acaf4107d340b7bfdac1e443 SHA512 de252e67f488f920538a15e69836d4b8779a3123e1913c78cb7d69833a8fa475eb1166928cc965bc7ad69aa26d3dc58395ac7d06fb2349120bd014939d81e229
DIST kwayland-integration-5.27.3.tar.xz 25700 BLAKE2B e286da319205f8c2655fd7ee0bb67807846aff7dde2d943c40300691195ae1ca8645f585d2d4086a5ecc353ba065c5b9c6725130418b82cc39a66105af46d22e SHA512 f9059b1b761d5c0fde8c84784f65576186e19e91a50586e5ddb33f7f2fef69a27dab6692c2239e168d3cb4d751d9d74f20a1c97616f0e24529393e98cefcd2a4
+DIST kwayland-integration-5.27.4.tar.xz 25724 BLAKE2B 660e090dd89c3f88870ed2fe853943935aa24841c41757fc792b0d2cc5b621da972ca9b7badbcbe9159618f33e524c52809485383f049e51122df3fddf29b3b3 SHA512 9916abb1697c7d3d6c1b27899c7aae0b4f009e5469ed125e617b594748a1601a771ba8bc15a877d6865a1fc353a35ecb0bcd40f6e89db7ef0b84b76843ae3773
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.27.4.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.27.4.ebuild
new file mode 100644
index 000000000000..079a05edc071
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.27.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module IdleTime
+ cmake_comment_add_subdirectory autotests # only contains idletime test
+ cmake_run_in src cmake_comment_add_subdirectory idletime
+}