summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-09 12:40:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-09 13:44:39 +0200
commitd26f2b068bcf024c6ad30fc227cc02eccbb797ae (patch)
tree1ac2b23f2ebc21dcad4a89018194a2226f0698dc /kde-plasma/libksysguard
parentdev-libs/libburn: Remove old libburn-1.5.0. (diff)
downloadgentoo-d26f2b068bcf024c6ad30fc227cc02eccbb797ae.tar.gz
gentoo-d26f2b068bcf024c6ad30fc227cc02eccbb797ae.tar.bz2
gentoo-d26f2b068bcf024c6ad30fc227cc02eccbb797ae.zip
kde-plasma: Add KDE Plasma 5.19.0
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/libksysguard')
-rw-r--r--kde-plasma/libksysguard/Manifest1
-rw-r--r--kde-plasma/libksysguard/files/libksysguard-5.18.90-unused-dep.patch92
-rw-r--r--kde-plasma/libksysguard/libksysguard-5.19.0.ebuild69
3 files changed, 162 insertions, 0 deletions
diff --git a/kde-plasma/libksysguard/Manifest b/kde-plasma/libksysguard/Manifest
index 1f37ba9ea9d0..1cd8cc23a80f 100644
--- a/kde-plasma/libksysguard/Manifest
+++ b/kde-plasma/libksysguard/Manifest
@@ -1 +1,2 @@
DIST libksysguard-5.18.5.tar.xz 610320 BLAKE2B c644bfa216ae851eb1520b9135add670ecbc4733be7bde27437a876141ca9f37c3531a78c347e7c00149e1d1f287a680954c3e885cfdc0838398626d6ed3d651 SHA512 a648d0db1378165188187db9de78f816b1dfe647ce7e7ea2d505bc04c5008d2c24b2a113bc73c4fc4b3ddf467682ea3b306286f4bffa2c750918112892d78fb3
+DIST libksysguard-5.19.0.tar.xz 666816 BLAKE2B 8a14bf2ef2e03917301304e569735d41467305b39f553c5d114a4bc07c4837380c0fcc102ab75cf44f62fb398675d25ae2efbedb080056de3407aa5b58ced65e SHA512 55285aec4e3b6b2837c24ad5f56abdc4d8d3360a7751a1943d6d826a7b536be46bdb6d5185eb15c87d58480be641806c53e72a36a3010b4b83f833314cbfa3e7
diff --git a/kde-plasma/libksysguard/files/libksysguard-5.18.90-unused-dep.patch b/kde-plasma/libksysguard/files/libksysguard-5.18.90-unused-dep.patch
new file mode 100644
index 000000000000..903b7b8bcf27
--- /dev/null
+++ b/kde-plasma/libksysguard/files/libksysguard-5.18.90-unused-dep.patch
@@ -0,0 +1,92 @@
+From fa06754147850ba06659f21e57cd7a724ecf8c49 Mon Sep 17 00:00:00 2001
+From: "Martin T. H. Sandsmark" <martin.sandsmark@kde.org>
+Date: Sat, 23 May 2020 18:26:12 +0200
+Subject: [PATCH] remove unnecessary dependency
+
+---
+ CMakeLists.txt | 13 +------------
+ signalplotter/CMakeLists.txt | 1 -
+ signalplotter/ksignalplotter.cpp | 2 +-
+ signalplotter/ksignalplotter_p.h | 2 ++
+ 4 files changed, 4 insertions(+), 14 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b12ead7..063cb05 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -46,14 +46,6 @@ set_package_properties(Qt5WebChannel PROPERTIES
+
+ find_package(KF5 REQUIRED COMPONENTS CoreAddons Config I18n JobWidgets WindowSystem Completion Auth WidgetsAddons IconThemes ConfigWidgets Service GlobalAccel KIO Package Declarative NewStuff)
+
+-find_package(KF5 OPTIONAL_COMPONENTS Plasma)
+-set_package_properties(KF5Plasma PROPERTIES
+- URL "https://cgit.kde.org/plasma-framework.git/"
+- DESCRIPTION "The library of the plasma project"
+- TYPE OPTIONAL
+- PURPOSE "Used by signalplotter to use Plasma themes"
+- )
+-
+ find_package(ZLIB REQUIRED)
+ set_package_properties(ZLIB PROPERTIES DESCRIPTION "Support for gzip compressed files and data streams"
+ URL "http://www.zlib.net"
+@@ -113,10 +105,7 @@ add_subdirectory( processcore )
+ add_subdirectory( processui )
+ add_subdirectory( sensors )
+ add_subdirectory( faces )
+-
+-if (KF5Plasma_FOUND)
+- add_subdirectory( signalplotter )
+-endif()
++add_subdirectory( signalplotter )
+ add_subdirectory( ksgrd )
+
+ if(BUILD_TESTING)
+diff --git a/signalplotter/CMakeLists.txt b/signalplotter/CMakeLists.txt
+index fd11f01..231fcf7 100644
+--- a/signalplotter/CMakeLists.txt
++++ b/signalplotter/CMakeLists.txt
+@@ -16,7 +16,6 @@ target_link_libraries(ksignalplotter
+ KF5::IconThemes
+ PRIVATE
+ KSysGuard::ProcessCore
+- KF5::Plasma
+ )
+
+ set_target_properties(ksignalplotter
+diff --git a/signalplotter/ksignalplotter.cpp b/signalplotter/ksignalplotter.cpp
+index 4e6c278..df7c705 100644
+--- a/signalplotter/ksignalplotter.cpp
++++ b/signalplotter/ksignalplotter.cpp
+@@ -42,7 +42,6 @@
+ #ifdef GRAPHICS_SIGNAL_PLOTTER
+ #include <QGraphicsSceneResizeEvent>
+ #include <QStyleOptionGraphicsItem>
+-#include <Plasma/Theme>
+ #endif
+
+ #include <klocalizedstring.h>
+@@ -52,6 +51,7 @@
+
+ #ifdef SVG_SUPPORT
+ #include <Plasma/Svg>
++#include <Plasma/Theme>
+ #endif
+
+
+diff --git a/signalplotter/ksignalplotter_p.h b/signalplotter/ksignalplotter_p.h
+index 81912f5..082f97c 100644
+--- a/signalplotter/ksignalplotter_p.h
++++ b/signalplotter/ksignalplotter_p.h
+@@ -24,7 +24,9 @@
+ //#define USE_QIMAGE
+
+ // SVG support causes it to crash at the moment :(
++// (when re-enabling this remember to also link against plasma-framework)
+ //#define SVG_SUPPORT
++
+ // Use a separate child widget to draw the graph in
+ #ifndef KSYSGUARD_KSIGNALPLOTTER_P_H
+ #define KSYSGUARD_KSIGNALPLOTTER_P_H
+--
+2.26.2
+
diff --git a/kde-plasma/libksysguard/libksysguard-5.19.0.ebuild b/kde-plasma/libksysguard/libksysguard-5.19.0.ebuild
new file mode 100644
index 000000000000..429c3f28c270
--- /dev/null
+++ b/kde-plasma/libksysguard/libksysguard-5.19.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+KFMIN=5.70.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.14.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Task management and system monitoring library"
+LICENSE="LGPL-2+"
+SLOT="5/9"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE="minimal webengine X"
+
+RDEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ sys-libs/zlib
+ webengine? (
+ >=dev-qt/qtwebchannel-${QTMIN}:5
+ >=dev-qt/qtwebengine-${QTMIN}:5
+ )
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ x11-libs/libXres
+ )
+"
+DEPEND="${RDEPEND}
+ !<kde-plasma/plasma-workspace-5.18.80:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ X? ( x11-base/xorg-proto )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.16.0-no-detailed-mem-message.patch"
+ "${FILESDIR}/${PN}-5.18.90-unused-dep.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package webengine Qt5WebChannel)
+ $(cmake_use_find_package webengine Qt5WebEngineWidgets)
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ LC_NUMERIC="C" ecm_src_test # bug 695514
+}