summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 12:18:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 18:46:51 +0200
commit7157547723b18d25136be06b136c9c66416e8758 (patch)
treedd0217948e3af92ee6c5def99df360bfcfb009f7 /kde-plasma/plasma-browser-integration
parentkde-plasma/oxygen: 5.22.5 version bump (diff)
downloadgentoo-7157547723b18d25136be06b136c9c66416e8758.tar.gz
gentoo-7157547723b18d25136be06b136c9c66416e8758.tar.bz2
gentoo-7157547723b18d25136be06b136c9c66416e8758.zip
kde-plasma/plasma-browser-integration: 5.22.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-browser-integration')
-rw-r--r--kde-plasma/plasma-browser-integration/Manifest1
-rw-r--r--kde-plasma/plasma-browser-integration/plasma-browser-integration-5.22.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-plasma/plasma-browser-integration/Manifest b/kde-plasma/plasma-browser-integration/Manifest
index 2a17b0564d9b..ac93fd3764c5 100644
--- a/kde-plasma/plasma-browser-integration/Manifest
+++ b/kde-plasma/plasma-browser-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-browser-integration-5.21.5.tar.xz 205668 BLAKE2B cf2eaff44d3bd4553e09b5802d01903be6d6a57acac312068a636af15a4daee44a855d3dfee771ff47b4de6a98e46f8d8225242986fc73d5e21eff6b1a59338c SHA512 83165c59606d32b65359ac7a9f79beabdcd50ea35becab2d6cfec3c34e0981a0bd0452176cf213e6de0db293b4adc1615631be6477048f5e8033cc5e16f1b9a0
DIST plasma-browser-integration-5.22.4.tar.xz 214528 BLAKE2B 8ca8b42a138b03e5bf4877f8407744ab79052a1549675b3111816044f22bf4aaafbd6748d90f4132ade1d4d2d8d847b528ec671b3a4e7e2b9b32744da4cbd558 SHA512 5be2468937542b2cc2037e9102cb861085a8f3a368d122ac4cabfa318306fb9a8b276223c30508d55588e51f6fca4da384f0c2a2f552120194f04bd588ef2d2d
+DIST plasma-browser-integration-5.22.5.tar.xz 214448 BLAKE2B 114baa04ab7fad7a3450c199b405afc3d0ce6c4a7e7cf8828dc15e509417de003ffb6b73a002b52b5d8a46f566a63320d33d23fdb8a60484e65c0176afcfadd1 SHA512 8cc29cc51c6cce4dd31677cff8851d58eb0dded0d41c52e0fa488a6f5a803c46b0f29ae02642707a039a283e19ea49fe2dac36604202282f6a62cd0f8716940a
diff --git a/kde-plasma/plasma-browser-integration/plasma-browser-integration-5.22.5.ebuild b/kde-plasma/plasma-browser-integration/plasma-browser-integration-5.22.5.ebuild
new file mode 100644
index 000000000000..93d643e0ab87
--- /dev/null
+++ b/kde-plasma/plasma-browser-integration/plasma-browser-integration-5.22.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Integrate Chrome/Firefox better into Plasma through browser extensions"
+HOMEPAGE+=" https://community.kde.org/Plasma/Browser_Integration"
+
+LICENSE="GPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kfilemetadata-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/krunner-${KFMIN}:5
+ >=kde-frameworks/purpose-${KFMIN}:5
+ >=kde-plasma/plasma-workspace-${PVCUT}:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMOZILLA_DIR="${EPREFIX}/usr/$(get_libdir)/mozilla"
+ )
+
+ ecm_src_configure
+}