summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-02-22 12:36:12 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-02-22 12:41:28 +0100
commit5cc6d781e408461e65e00320c7e1c14dc2e38247 (patch)
tree36d373c37f8dbba7b505d8e587f395372531f462 /kde-plasma/plasma-desktop/files
parentmedia-libs/libilbc: Add architecture definition for ppc/ppc64 (bug 610546). (diff)
downloadgentoo-5cc6d781e408461e65e00320c7e1c14dc2e38247.tar.gz
gentoo-5cc6d781e408461e65e00320c7e1c14dc2e38247.tar.bz2
gentoo-5cc6d781e408461e65e00320c7e1c14dc2e38247.zip
kde-plasma: KDE Plasma 5.8.6 version bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'kde-plasma/plasma-desktop/files')
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.8.6-baloo-optional.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.6-baloo-optional.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.6-baloo-optional.patch
new file mode 100644
index 000000000000..016a34b4284c
--- /dev/null
+++ b/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.6-baloo-optional.patch
@@ -0,0 +1,51 @@
+commit e56ffb0914d5498f4017b0046524009d2b617876
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Thu Sep 15 00:39:43 2016 +0200
+
+ Make KF5Baloo optional
+
+ Regardless of the current state of Baloo, it is not very deeply tied
+ into Plasma. Usage in plasma-desktop comes down to providing the
+ file search kcm. This makes it possible to prepare systems without a
+ use for indexing.
+
+ https://mail.kde.org/pipermail/kde-frameworks-devel/2016-September/037734.html
+
+ REVIEW: 128957
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8c99352..b229dd5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -67,14 +67,10 @@ set_package_properties(PackageKitQt5 PROPERTIES DESCRIPTION "Software Manager in
+ PURPOSE "Provides package management integration to the application launcher."
+ )
+
+-# Baloo is currently part of the KF5 namespace, but it is not
+-# a proper framework. Hence the strange versioning.
+-# This will be fixed with Plasma 5.2, as Baloo should have
+-# become a framework by then
+ find_package(KF5Baloo "5.24")
+ set_package_properties(KF5Baloo PROPERTIES DESCRIPTION "File Searching"
+- TYPE REQUIRED
+- PURPOSE "Needed to build to File Search KCM"
++ TYPE RECOMMENDED
++ PURPOSE "Needed to build the File Search KCM"
+ )
+
+ find_package(Fontconfig)
+diff --git a/kcms/CMakeLists.txt b/kcms/CMakeLists.txt
+index 53ca49a..3220bd3 100644
+--- a/kcms/CMakeLists.txt
++++ b/kcms/CMakeLists.txt
+@@ -55,7 +55,9 @@ add_subdirectory(useraccount/pics)
+
+
+ add_subdirectory(workspaceoptions)
+-add_subdirectory(baloo)
++if (KF5Baloo_FOUND)
++ add_subdirectory(baloo)
++endif()
+ add_subdirectory(solid_actions)
+ add_subdirectory(cursortheme)
+