summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-17 23:04:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-18 00:48:41 +0100
commit23cc71974f081f1336a61547086f64c8f2165a60 (patch)
tree8479d3f65c7c216237bb1d74595d83fe0ce8a2f4 /kde-plasma/plasma-desktop
parentkde-plasma/plasma-desktop: Fix jagginess for activities list icons (diff)
downloadgentoo-23cc71974f081f1336a61547086f64c8f2165a60.tar.gz
gentoo-23cc71974f081f1336a61547086f64c8f2165a60.tar.bz2
gentoo-23cc71974f081f1336a61547086f64c8f2165a60.zip
kde-plasma/plasma-desktop: Fix Pager doesn't show windows of 2nd screen
KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=414849 Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-desktop')
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.17.4-pager-regression.patch25
-rw-r--r--kde-plasma/plasma-desktop/plasma-desktop-5.17.4-r1.ebuild1
2 files changed, 26 insertions, 0 deletions
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.17.4-pager-regression.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.17.4-pager-regression.patch
new file mode 100644
index 000000000000..d8057f22a4c2
--- /dev/null
+++ b/kde-plasma/plasma-desktop/files/plasma-desktop-5.17.4-pager-regression.patch
@@ -0,0 +1,25 @@
+From 2b5e86323f180f0c51ef9af898a69a522bc379ad Mon Sep 17 00:00:00 2001
+From: David Faure <faure@kde.org>
+Date: Sat, 14 Dec 2019 00:29:32 +0100
+Subject: Fix regression in "Port the pager applet away from QtWidgets"
+
+BUG: 414849
+---
+ applets/pager/plugin/windowmodel.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/applets/pager/plugin/windowmodel.cpp b/applets/pager/plugin/windowmodel.cpp
+index 93273bb..bcda333 100644
+--- a/applets/pager/plugin/windowmodel.cpp
++++ b/applets/pager/plugin/windowmodel.cpp
+@@ -77,7 +77,7 @@ QVariant WindowModel::data(const QModelIndex &index, int role) const
+ if (role == AbstractTasksModel::Geometry) {
+ QRect windowGeo = TaskFilterProxyModel::data(index, role).toRect();
+ QList<QScreen *> screens = QGuiApplication::screens();
+- const QRect desktopGeo = screens.at(0)->geometry();
++ const QRect desktopGeo = screens.at(0)->virtualGeometry();
+
+ if (KWindowSystem::mapViewport()) {
+ int x = windowGeo.center().x() % desktopGeo.width();
+--
+cgit v1.1
diff --git a/kde-plasma/plasma-desktop/plasma-desktop-5.17.4-r1.ebuild b/kde-plasma/plasma-desktop/plasma-desktop-5.17.4-r1.ebuild
index 34554e995197..f0f08a65f980 100644
--- a/kde-plasma/plasma-desktop/plasma-desktop-5.17.4-r1.ebuild
+++ b/kde-plasma/plasma-desktop/plasma-desktop-5.17.4-r1.ebuild
@@ -117,6 +117,7 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}"/${P}-activities-kcm-hidpi.patch
+ "${FILESDIR}"/${P}-pager-regression.patch
)
src_configure() {