summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-03-21 17:29:56 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-03-21 17:29:56 +0100
commitd5b01ef76733ee348536597058e67f6096eac312 (patch)
treedd2897de15bf6c8c1326791dd8427c5b6fea6dcc /kde-plasma/plasma-desktop
parentkde-plasma: Drop KDE Plasma 5.9.3 (diff)
downloadgentoo-d5b01ef76733ee348536597058e67f6096eac312.tar.gz
gentoo-d5b01ef76733ee348536597058e67f6096eac312.tar.bz2
gentoo-d5b01ef76733ee348536597058e67f6096eac312.zip
kde-plasma: Drop unused patches
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-plasma/plasma-desktop')
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.7.90-baloo-optional.patch45
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-crashfix.patch57
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-folder-view-script-execution.patch28
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-hover-state.patch33
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-taskman-memleak.patch43
5 files changed, 0 insertions, 206 deletions
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.7.90-baloo-optional.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.7.90-baloo-optional.patch
deleted file mode 100644
index 86fc43c502c3..000000000000
--- a/kde-plasma/plasma-desktop/files/plasma-desktop-5.7.90-baloo-optional.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-commit 00cdef0f2b6e8e20661aef98074b8533103bbfdd
-Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Thu Sep 15 00:39:43 2016 +0200
-
- Make KF5Baloo optional
-
- https://mail.kde.org/pipermail/kde-frameworks-devel/2016-September/037734.html
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f15021a..613ca20 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -67,14 +67,10 @@ set_package_properties(PackageKitQt5 PROPERTIES DESCRIPTION "Software Manager in
- PURPOSE "Provides package management integration to the application launcher."
- )
-
--# Baloo is currently part of the KF5 namespace, but it is not
--# a proper framework. Hence the strange versioning.
--# This will be fixed with Plasma 5.2, as Baloo should have
--# become a framework by then
--find_package(KF5Baloo "5.1.90")
-+find_package(KF5Baloo)
- set_package_properties(KF5Baloo PROPERTIES DESCRIPTION "File Searching"
-- TYPE REQUIRED
-- PURPOSE "Needed to build to File Search KCM"
-+ TYPE OPTIONAL
-+ PURPOSE "Needed to build the File Search KCM"
- )
-
- find_package(Fontconfig)
-diff --git a/kcms/CMakeLists.txt b/kcms/CMakeLists.txt
-index 53ca49a..3220bd3 100644
---- a/kcms/CMakeLists.txt
-+++ b/kcms/CMakeLists.txt
-@@ -55,7 +55,9 @@ add_subdirectory(useraccount/pics)
-
-
- add_subdirectory(workspaceoptions)
--add_subdirectory(baloo)
-+if (KF5Baloo_FOUND)
-+ add_subdirectory(baloo)
-+endif()
- add_subdirectory(solid_actions)
- add_subdirectory(cursortheme)
-
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-crashfix.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-crashfix.patch
deleted file mode 100644
index 9e4bdd99f5c4..000000000000
--- a/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-crashfix.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-commit d674ede6e5f22281fa2461546ddc25ff5f3a7015
-Author: Kai Uwe Broulik <kde@privat.broulik.de>
-Date: Tue Jan 3 09:38:50 2017 +0100
-
- [Panel Containment] Explicitly bind visible on both the container and the applet
-
- While trying to fix a random plasmashell crash I was getting fairly often (and I hoped
- was fixed by David's last spacer fix) I found that the cause was actually in virtual desktop pager.
-
- The virtual desktop pager is hidden when there's just one desktop and it will not update its
- models in this case to save resources. Back when I added this I already noticed that sometimes
- the pager (usually after one "open and close panelcontroller" cycle) still thought it was visible.
- It was even weirder than that, I found out that on teardown it suddenly thought it became visible.
- This had it populate its model which in turn spawned QML items, all of this whilst the panel was
- already in the process of destroying its children, leading to a crash.
-
- Differential Revision: https://phabricator.kde.org/D3897
-
-diff --git a/containments/panel/contents/ui/main.qml b/containments/panel/contents/ui/main.qml
-index e9afa86..5bb5283 100644
---- a/containments/panel/contents/ui/main.qml
-+++ b/containments/panel/contents/ui/main.qml
-@@ -54,20 +54,27 @@ DragDrop.DropArea {
-
- //BEGIN functions
- function addApplet(applet, x, y) {
-+ // don't show applet if it choses to be hidden but still make it
-+ // accessible in the panelcontroller
-+ // Due to the nature of how "visible" propagates in QML, we need to
-+ // explicitly set it on the container (so the Layout ignores it)
-+ // as well as the applet (so it reliably knows about), otherwise it can
-+ // happen that an applet erroneously thinks it's visible, or suddenly
-+ // starts thinking that way on teardown (virtual desktop pager)
-+ // leading to crashes
-+ var visibleBinding = Qt.binding(function() {
-+ return applet.status !== PlasmaCore.Types.HiddenStatus || (!plasmoid.immutable && plasmoid.userConfiguring);
-+ })
-+
- var container = appletContainerComponent.createObject(root, {
- applet: applet,
--
-- // don't show applet if it choses to be hidden but still make it
-- // accessible in the panelcontroller
-- visible: Qt.binding(function() {
-- return applet.status !== PlasmaCore.Types.HiddenStatus || (!plasmoid.immutable && plasmoid.userConfiguring)
-- })
-+ visible: visibleBinding
- });
-
- applet.parent = container;
- applet.anchors.fill = container;
-
-- applet.visible = true;
-+ applet.visible = visibleBinding;
-
- // Is there a DND placeholder? Replace it!
- if (dndSpacer.parent === currentLayout) {
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-folder-view-script-execution.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-folder-view-script-execution.patch
deleted file mode 100644
index d8376d87d5c7..000000000000
--- a/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-folder-view-script-execution.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-commit 771e57f3b2c19f4e6f867c01c2457ec87531b4cf
-Author: Kai Uwe Broulik <kde@privat.broulik.de>
-Date: Tue Jan 31 15:07:42 2017 +0100
-
- [Folder View] show script execution prompt when clicking item
-
- When clicking a file in FolderView, we should ask for whether to open or run a script depending on user settings.
- This is what Dolphin does.
-
- BUG: 375793
- FIXED-IN: 5.8.6
-
- Differential Revision: https://phabricator.kde.org/D4367
-
-diff --git a/containments/desktop/plugins/folder/foldermodel.cpp b/containments/desktop/plugins/folder/foldermodel.cpp
-index 758f7f35..1ba12450 100644
---- a/containments/desktop/plugins/folder/foldermodel.cpp
-+++ b/containments/desktop/plugins/folder/foldermodel.cpp
-@@ -509,7 +509,8 @@ void FolderModel::run(int row)
- url.setScheme(QStringLiteral("file"));
- }
-
-- new KRun(url, 0);
-+ KRun *run = new KRun(url, 0);
-+ run->setShowScriptExecutionPrompt(true);
- }
-
- void FolderModel::rename(int row, const QString& name)
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-hover-state.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-hover-state.patch
deleted file mode 100644
index 5e645c51b063..000000000000
--- a/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-hover-state.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-commit e80a4b87cfa98708724942794ca6f051974bb5c0
-Author: Eike Hein <hein@kde.org>
-Date: Tue Jan 3 16:30:54 2017 +0900
-
- Don't clear hover state while a child dialog is open.
-
- Otherwise it won't stay open.
-
- Fixes regression from 7585f295363532eff51f7e11ef6b62925117aba4.
-
- The bug number referenced in the original change is invalid, but
- I don't think this should invalidate the intent of that fix. Kai
- please let me know the correct bug number so I can double-check.
-
- BUG:374291
- CCMAIL:kde@privat.broulik.de
-
-diff --git a/containments/desktop/package/contents/ui/FolderView.qml b/containments/desktop/package/contents/ui/FolderView.qml
-index 1fd8dbb..8936532 100644
---- a/containments/desktop/package/contents/ui/FolderView.qml
-+++ b/containments/desktop/package/contents/ui/FolderView.qml
-@@ -343,7 +343,10 @@ Item {
- onContainsMouseChanged: {
- if (!containsMouse && !main.rubberBand) {
- clearPressState();
-- gridView.hoveredItem = null;
-+
-+ if (gridView.hoveredItem && !gridView.hoveredItem.popupDialog) {
-+ gridView.hoveredItem = null;
-+ }
- }
- }
-
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-taskman-memleak.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-taskman-memleak.patch
deleted file mode 100644
index b112edced777..000000000000
--- a/kde-plasma/plasma-desktop/files/plasma-desktop-5.8.5-taskman-memleak.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-commit 58e932c607db27bea2872625661991fb16c79d13
-Author: Kai Uwe Broulik <kde@privat.broulik.de>
-Date: Tue Jan 3 09:37:38 2017 +0100
-
- [Task Manager] Parent QAction to "parent" instead of this
-
- This ensures the QAction is disposed of once the menu gets destroyed rather than
- accumulating forever - the methods already took a "parent" argument,
- which is passed the menu from QML side, for exactly that purpose.
-
- Differential Revision: https://phabricator.kde.org/D3816
-
-diff --git a/applets/taskmanager/plugin/backend.cpp b/applets/taskmanager/plugin/backend.cpp
-index 16f1f57..efbd095 100644
---- a/applets/taskmanager/plugin/backend.cpp
-+++ b/applets/taskmanager/plugin/backend.cpp
-@@ -142,7 +142,7 @@ QVariantList Backend::jumpListActions(const QUrl &launcherUrl, QObject *parent)
- continue;
- }
-
-- QAction *action = new QAction(this);
-+ QAction *action = new QAction(parent);
- action->setText(name);
- action->setIcon(QIcon::fromTheme(actionGroup.readEntry("Icon")));
- action->setProperty("exec", exec);
-@@ -204,7 +204,7 @@ QVariantList Backend::recentDocumentActions(const QUrl &launcherUrl, QObject *pa
- continue;
- }
-
-- QAction *action = new QAction(this);
-+ QAction *action = new QAction(parent);
- action->setText(url.fileName());
- action->setIcon(QIcon::fromTheme(fileItem.iconName(), QIcon::fromTheme("unknown")));
- action->setProperty("agent", storageId);
-@@ -219,7 +219,7 @@ QVariantList Backend::recentDocumentActions(const QUrl &launcherUrl, QObject *pa
- }
-
- if (actionCount > 0) {
-- QAction *action = new QAction(this);
-+ QAction *action = new QAction(parent);
- action->setText(i18n("Forget Recent Documents"));
- action->setProperty("agent", storageId);
- connect(action, &QAction::triggered, this, &Backend::handleRecentDocumentAction);