summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 10:58:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 11:07:37 +0200
commit03b5070fa51fa15ac47489fae77811eaa07e1b91 (patch)
tree891706a5e6725e4f37f331422302e6d53a82aa6a /kde-plasma/plasma-nm
parentwww-apps/mediawiki: fixed test in postupgrade file (diff)
downloadgentoo-03b5070fa51fa15ac47489fae77811eaa07e1b91.tar.gz
gentoo-03b5070fa51fa15ac47489fae77811eaa07e1b91.tar.bz2
gentoo-03b5070fa51fa15ac47489fae77811eaa07e1b91.zip
kde-plasma: Add KDE Plasma 5.16.0
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.16.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 6f69d6a58735..2cead8cc19b3 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1 +1,2 @@
DIST plasma-nm-5.15.5.tar.xz 777140 BLAKE2B d75ad6c04587f5bc115268f2bef50e0f6dd2b8b86957ab1f43e284988039fb7d9530cb03d86f5c49bdf6747bbb6ad123c7bc527643fe7461ed91efc93c63e563 SHA512 f3f78f40b754de5afbd63c5713e684fe3d37ae25af5a9e6ba808647e0d7d4f23456ed4b94aa8138e1fab99e7f7d7e0dffb697e0e46c99bd312bad5e2a7b9833f
+DIST plasma-nm-5.16.0.tar.xz 782396 BLAKE2B 9ec49f3db478d207c3d44804b1d5fc4f0a8ada1a55e99e4eb2ab8f627523f9aca28f8cf203c6b232cc67709cd90ce17a061edbc3480fad81a1f663306b33c193 SHA512 eeaf8e0a1575c1211311a3996f34cfb4c4065addeb0f72f8a8c83cda79b725def5177f8e531763480a8c28dc5c11b6656ea22871b0e050aa5b84d40de4038ba1
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.16.0.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.16.0.ebuild
new file mode 100644
index 000000000000..995f4b6b6b89
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.16.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-vpn/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}