summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-13 11:35:38 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-14 12:26:20 +0100
commit25c9eaa936db02ebc66f3554400aed7aa0c09117 (patch)
tree1196bf9571981812b7ff8405f4a97ea6f3972918 /kde-plasma/plasma-nm
parentkde-plasma/plasma-meta: 5.27.0 version bump (diff)
downloadgentoo-25c9eaa936db02ebc66f3554400aed7aa0c09117.tar.gz
gentoo-25c9eaa936db02ebc66f3554400aed7aa0c09117.tar.bz2
gentoo-25c9eaa936db02ebc66f3554400aed7aa0c09117.zip
kde-plasma/plasma-nm: 5.27.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.27.0.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 0880ca077606..e42e79c1ef81 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,2 +1,3 @@
DIST plasma-nm-5.26.5.tar.xz 972940 BLAKE2B 4f10049a0a946b67fd0638913c365558a8e95b80d1d896323f4030738f8dd4d07cc77c4aaf212c52d8ba89635d932369d2f69e134722d24a5eed41841b15409a SHA512 bb17b06de15cc5b36d1eedd4fc8551eff240f8e61a4a036450b2365c99eb5885adc9541c29aa95b311d79d57b62ab95f41b746402cb6de7ecee6c6c4e87ac9a3
DIST plasma-nm-5.26.90.tar.xz 1146752 BLAKE2B c003beb209a6750e07456e44e203cf2ff8f8da7768367b1f79ad95774314b9ab2f71ec104c8321940497564a06c03ca442e800834aa1c201ee1067bfe6c262ec SHA512 d3fc26d80c63014f58e9f6a4f40bd73870ac9e69e573c1a7cde16d60d18cd1b64750016efd35d66ae338c0d6fce2af1a7602ebb83a9c7917e98efb70700e9493
+DIST plasma-nm-5.27.0.tar.xz 1147804 BLAKE2B e069ec32c62f2b7e2f1499e70ec50c5fbf30d19b1e8c43bba3252beb60c65f8fabceb1688387b0dccbc93813778b7c37769eecef9fc1141fc0cf5de049f01af5 SHA512 78773052d3ab4dff64dbbe3a169250618df4a01848f0fd7c5acbe31e07b8f61390f5f1ed072bd62a3b091fd4f99acec26e47b341886e5cf6032b5c149c5608ea
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.27.0.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.27.0.ebuild
new file mode 100644
index 000000000000..420f8ce7353d
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.27.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="openconnect teamd"
+
+DEPEND="
+ >=app-crypt/qca-2.3.0:2[qt5(+)]
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5[widgets]
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/modemmanager-qt-${KFMIN}:5
+ >=kde-frameworks/networkmanager-qt-${KFMIN}:5[teamd=]
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ net-misc/networkmanager[teamd=]
+ >=dev-qt/qtxml-${QTMIN}:5
+ net-misc/mobile-broadband-provider-info
+ openconnect? (
+ >=dev-qt/qtxml-${QTMIN}:5
+ net-vpn/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/kquickcharts-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+"
+BDEPEND="
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # TODO: try to get a build switch upstreamed
+ if ! use openconnect; then
+ sed -e "s/^pkg_check_modules.*openconnect/#&/" -i CMakeLists.txt || die
+ fi
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}