summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-21 22:59:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-23 15:48:43 +0200
commitb8dcf727646a2ce79e07d2d0490f80ebf58cc616 (patch)
tree5b265646a0d909e76f293110087c7335d32bd9fe /kde-plasma/plasma-nm
parentkde-frameworks/plasma: Drop 5.71.0 (r0) (diff)
downloadgentoo-b8dcf727646a2ce79e07d2d0490f80ebf58cc616.tar.gz
gentoo-b8dcf727646a2ce79e07d2d0490f80ebf58cc616.tar.bz2
gentoo-b8dcf727646a2ce79e07d2d0490f80ebf58cc616.zip
kde-plasma/plasma-nm: [2/2] Fix password is asked twice
See also: https://mail.kde.org/pipermail/distributions/2020-June/000367.html KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=423093 Upstream commit 271332cfc19ede398854113d037abfb35503179f "[applet] Fix inline password field component not working properly" Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/files/plasma-nm-5.19.2-fix-inline-password-field.patch30
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.19.2.ebuild4
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/files/plasma-nm-5.19.2-fix-inline-password-field.patch b/kde-plasma/plasma-nm/files/plasma-nm-5.19.2-fix-inline-password-field.patch
new file mode 100644
index 000000000000..170e20ea2256
--- /dev/null
+++ b/kde-plasma/plasma-nm/files/plasma-nm-5.19.2-fix-inline-password-field.patch
@@ -0,0 +1,30 @@
+From 271332cfc19ede398854113d037abfb35503179f Mon Sep 17 00:00:00 2001
+From: Nate Graham <nate@kde.org>
+Date: Thu, 18 Jun 2020 15:34:40 +0000
+Subject: [PATCH] [WIP] [applet] Fix inline password field component not
+ working properly
+
+BUG: 423093
+FIXED-IN: 5.20
+---
+ applet/contents/ui/ConnectionItem.qml | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/applet/contents/ui/ConnectionItem.qml b/applet/contents/ui/ConnectionItem.qml
+index 98240928..06c7ab25 100644
+--- a/applet/contents/ui/ConnectionItem.qml
++++ b/applet/contents/ui/ConnectionItem.qml
+@@ -231,8 +231,8 @@ PlasmaExtras.ExpandableListItem {
+ if (!predictableWirelessPassword && !Uuid) {
+ handler.addAndActivateConnection(DevicePath, SpecificPath)
+ } else if (connectionItem.customExpandedViewContent == passwordDialogComponent) {
+- if (passwordDialogComponent.password != "") {
+- handler.addAndActivateConnection(DevicePath, SpecificPath, passwordDialogComponent.password)
++ if (connectionItem.customExpandedViewContentItem.password != "") {
++ handler.addAndActivateConnection(DevicePath, SpecificPath, connectionItem.customExpandedViewContentItem.password)
+ connectionItem.customExpandedViewContent = detailsComponent
+ connectionItem.collapse()
+ } else {
+--
+2.27.0
+
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.19.2.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.19.2.ebuild
index 7ae4e64126b3..4d75d3c41a75 100644
--- a/kde-plasma/plasma-nm/plasma-nm-5.19.2.ebuild
+++ b/kde-plasma/plasma-nm/plasma-nm-5.19.2.ebuild
@@ -61,6 +61,10 @@ RDEPEND="${DEPEND}
>=kde-plasma/kde-cli-tools-${PVCUT}:5
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.19.2-fix-inline-password-field.patch # KDE-bug #423093
+)
+
src_configure() {
local mycmakeargs=(
-DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)